trying to follow some tutorials about accessing serial ports, I kept getting a permission denied error for /dev/serial0, and the common solution seemed to be to add the user to the dialout group... except in my case serial0 is owned by root:root

lrwxrwxrwx   1 root root        5 Aug 21 20:16 serial0 -> ttyS0

I tried chown root:dialout /dev/serial0, and not only did I still get Permission Denied, but upon reboot, the ownership changed back to root:root.

almost all documentation and answers I see show this should be root:dialout. so what's going on with my install? and how do I get access to the serial port without root?

I'm running a recent install of Pi OS with Debian GNU/Linux 11 (bullseye)

EDIT: turns out I had serial console enabled within raspi-config, once I disabled that, and only had serial port enabled, I no longer receieved the error.

1 Answer 1


This is NOT an error!

/dev/serial0 is a link; the device to which it links /dev/ttyAMA0 or /dev/ttyS0 is a member of dialout.

NOTE unless you enable serial there will be no /dev/serial0.

See How do I make serial work on the Raspberry Pi3 or later

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.