1

I have tried every option I could find, but no matter what I try, after rebooting my Raspberry Pi 400 running Ubuntu Server 22.04 the WiFi power management feature resets to ON, meaning the WiFi goes to sleep after periods of inactivity and makes the whole device completely inaccessible when I need it.

****@****:~$ iwconfig wlan0
wlan0     IEEE 802.11  ESSID:"***********"  
          Mode:Managed  Frequency:5.22 GHz  Access Point: *********   
          Bit Rate=54 Mb/s   Tx-Power=31 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=38/70  Signal level=-72 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Here are some of the fixes I've tried, which have apparently worked for others.

Is there any other that I may have missed?

1 Answer 1

0

I had something similar with wifi switching off on a desktop machine. I eventually tracked it down to a system change which now forced sleep buried deep in some setting I was unaware of.

If I remember correctly I had to use a command like the following.

sudo systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.