3

I am using latest the Raspbian Wheezy release with kernel 3.10. I am running four Python programs 24 hours/day on the Raspberry Pi. Three programs out of four are like background services, which consume at the maximum 2.4% CPU and around 1.2% memory each. The fourth Python code is a pygame application that is displayed on a 1920x1080 screen, which consumes about 50% CPU and 2.4% memory. Thus in total when I am running all 4 programs total memory used is 90 MB and 60% CPU is in use all the time.

The problem is that Raspberry Pi suddenly hangs (no response the keyboard nor mouse, and I'm also not able to ping) after 2-3 days and thus we have to reboot it forcefully. What could be the reason for it to hang? There is no problem of a memory leak since even after 2-3 days the total memory usage and CPU usage is unchanged.

  • Possibly check your temps. I don't expect it but there could be a chance at those resolutions the temperature causes a crash. Strange it happens after such a long period, usually is memory leaks but as you say monitoring didn't point to that being the issue either. – munkee Feb 22 '14 at 13:29
  • 1
    What do you mean by "hangs"? Have you checked the system logs? – goldilocks Feb 22 '14 at 18:29
  • By "hangs" I mean the raspberry doesn't respond to anything like keyboard, mouse and also I am not able to ping raspberry pi. Only devices which are connected to raspberry are ethernet cable, keyboard, mouse and HDTV using hdmi cable. – prattom Feb 26 '14 at 7:55
  • I checked system logs but it didn't show anything. – prattom Feb 26 '14 at 7:56
5

What do you mean by "hang"? I had problems with my headless pi that every 2-3 days I could not connect to it. It was working ok but I could not ping nor ssh to it. Turned out to be a problem with the power management in the wifi dongle:

http://www.raspberrypi.org/phpBB3/viewtopic.php?t=51543&p=397663

Once I turned of the power management features as described in the link it worked continuously again

  • People ought not to buy anything wifi based in realtek chips. My pi also hanged until I switched the realtek one to a ralink. – Rui F Ribeiro Jul 7 '16 at 11:59
0

If you overclocked, double check that and maybe set a lower frequency. One does not simply set "Turbo" or "Pi2" as an overclock in raspi-config. I've experienced this with extreme stress testing and a serious overclock. Clocking down solved my issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.