0

I have a problem setting up a new RaspPi Pico. I pressed the BOOTSEL button, connected it via USB to my Windows machine and released the button. I copied the .uf2 file previously downloaded for this version of the Pico (regular Pico, without WLAN) from raspberrypi.com. It rebooted and I re-connected it. I installed Thonny and wanted to select MicroPython on the bottom right, but it was not available. The Pico had disconnected. Again, I pressed the BOOTSEL button and connected the Pico. Now, Thonny gave me the option to install MicroPython. I tried this 3 or 4 times, always with the same events happening:

  1. Press BOOSEL, connect via USB, release BOOTSEL
  2. Select install MicroPython v. 1.19.1 in Thonny
  3. Copying files 1...100 %
  4. Port not found! Thonny says "Done!" anyway, but MicroPython cannot be selected.
  5. Pico was unmounted for some reason

Here is the Thonny output during installation attempts:

Downloading from https://micropython.org/resources/firmware/rp2-pico-20220618-v1.19.1.uf2
Writing to H:\rp2-pico-20220618-v1.19.1.uf2
100%
Waiting for the port...
Warning: Could not find port in 10 seconds

Done!

What have I done wrong or where is the problem? Has someone encountered a similar issue?

1
  • 1
    Ah this is a common problem, not confined to Pico installation. Usually Windows tries to be clever and finds a new port when asked to install the same package again. A troubleshooting trick to use the control panel to check out what ports are being used.
    – tlfong01
    Sep 3, 2022 at 13:33

1 Answer 1

1

As @tlfong01 pointed out, this appears to be a Windows related issue. I "solved" it in the simplest possible way: by using a notebook running Linux to connect with the Pico.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.