0

I am using RaspberryPi OS Lite on my model 3B on a 8Gb SD card, but ran out of space. I tried copying the old SD card using

  • dd on the whole SD Card
  • dd on both partitions separately
  • balenaEtcher (clone drive)
  • various other tools for cloning drives

but no matter what I did, when I tried to boot I got a kernel panic because /sbin/init exists but couldn't be executed. I also tried changing fstab and cmdline.txt replacing the PARTUUID for the root partition with /dev/mmcblk0p2. My old SD still booted but it had no effect on my new SD Card. I could not find any guide that doesn't use these steps.

6
  • Your question has been asked, and answered
    – Seamus
    Commented Sep 4, 2022 at 20:39
  • This shell script solved my problem: github.com/billw2/rpi-clone Commented Sep 4, 2022 at 21:12
  • It might be a solution that works, but in the end I used a different tool that is easier to use and does exactly what I need. (see answer) Commented Sep 4, 2022 at 21:18
  • In that case you should add an answer to the previous existing question, but as per your (deleted) answer here, that should contain meaningful content beyond a pasted link.
    – goldilocks
    Commented Sep 4, 2022 at 21:41
  • I have a different problem than the author of the previous question. Copying to a larger SD card is different than copying to a smaller SD card and therefore deserves its own thread imo Commented Sep 4, 2022 at 22:11

0

Browse other questions tagged or ask your own question.