1

This question already has an answer here:

I have a raspberry pi being powered by a cellphone charger (1A)

I try to connect and HDD but the power is not enough. I don´t have a powered USB hub BUT i do have other power supplies. So I tried powering the HDD by myself.. but I cannot.

I tried:

I have a Y USB cable, I shortcuted the red wire from the endpoint that goes to the power suply and the HDD. So it does NOT backpower my PI. I tried 1A and 2A in the charger here. Nothing works

enter image description here I also tried using the 2A adapter to power the Pi and connect the HDD to the USB thinking that 2A should be enough for everything. But it is not

I checked the specifications of the HDD and it says 5V and 1A so .... No clue why it fails.

IF I plug the HDD to my desktop PC it has no problem working. But in the Pi it starts and stops all the time making ugly noises

Any clue ??

marked as duplicate by Milliways, RPiAwesomeness, syb0rg, lenik, Impulss Mar 6 '14 at 5:40

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Did you try that setup on Windows/Linux/Mac machine? Does it detect it in a nomral PC? Cutting USB cables interference issues. Try disconnecting the negative from the Pi. That could be causing loop back noise. Generally the 5Vcc and GND power the SATA controller and the spindles on the HDD and the DATA lines negotiate their own speeds, regardless of power supply. But I think you messed up your USB cable. – Piotr Kula Feb 23 '14 at 16:06
  • @ppumpkin cutting the negative i.e. the common ground is likely to cause more problems. – Milliways Feb 23 '14 at 22:58
  • we know that for performing communication between the HDD and the PI they must share the negative. @ppumkin have you ever tried that and worked ?? BTW the HD does work flawlessly in a desktop PC – javirs Feb 24 '14 at 7:40
  • Yea the GND must be common. You right. THis is weird then. – Piotr Kula Feb 24 '14 at 9:22
  • Does it work in your desktop with the above power cabling? If it works directly, is your desktop USB 3.0? – deed02392 Feb 24 '14 at 12:19

Browse other questions tagged or ask your own question.