1

I have a rPi4 using it with Pi cam 1.3.

Tried with

camera = PiCamera()
camera.start_preview()
sleep(5)
camera.capture('/tmp/picture.jpg')
camera.stop_preview()

but does not pop up anything, but the image is saved.

same with raspistill

What should I do to see the image of my cam?

1 Answer 1

0

You may be either using VNC or SSH to connect to the Pi. If that's the case, you won't be able to see the image pop-up, and you now have two options to fix that.

  1. Connecting the Pi to a monitor using HDMI
  2. Turning on Direct Capture Mode on RPi's VNC server.

For option 2, connect to your Pi via VNC, open the VNC Server dialog, navigate Menu > Options > Troubleshooting, and select Enable direct capture mode. Finally, reconnect the VNC connection.

OR, if you're on the Pi with an HDMI-connected monitor, check which desktop driver you're using from raspi-config -> Advanced Options -> GL-driver. Then set the driver to G3 Legacy, if necessary.

Give us updates in the comments.

3
  • I'm on it with a directly connected monitor
    – Korte Alma
    Sep 20, 2022 at 5:16
  • Do you have KMS/OpenGL enabled? (set via raspi-config ) If it's either full or fake, change it back to legacy. The full KMS driver means ARM gets total control over the display pipeline, which prevents the GPU from adding the camera layers. Sep 20, 2022 at 17:39
  • Nope, that not working also
    – Korte Alma
    Sep 28, 2022 at 16:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.