0

I am working on creating a cluster with two Raspberry PIs. I was able to access both of them using Putty on my Windows 10 machine.

EDIT 1

Since a reboot, I am unable to access one of the Raspberry PIs 3 from Putty due to a : Putty Fatal Error Network error: Connection timed out. enter image description here

  • The SSH is enabled on that Raspberry PI and the behavior is normal when I plug on it a monitor, mouse and keyboard (I can not always do this, that's why I'm searching for a solution to make it work again with Putty from my windows machine).
  • I am able to ping the Raspberry PI from the windows machine
  • As I found in some similar posts, I also added an empty SSH file without any change.
  • Here are the outputs of some checks:
$ sudo ufw status
Status: active

To                         Action      From
--                         ------      ----
2377/tcp                   ALLOW       Anywhere                  
7946/tcp                   ALLOW       Anywhere                  
7946/udp                   ALLOW       Anywhere                  
4789/udp                   ALLOW       Anywhere                  
2377/tcp (v6)              ALLOW       Anywhere (v6)            
7946/tcp (v6)              ALLOW       Anywhere (v6)            
7946/udp (v6)              ALLOW       Anywhere (v6)            
4789/udp (v6)              ALLOW       Anywhere (v6)            
$ sudo systemctl status ssh
● ssh.service - OpenBSD Secure Shell server
   Loaded: loaded (/lib/systemd/system/ssh.service; enabled; vendor preset: enab
   Active: active (running) since Thu 2022-09-22 09:29:45 BST; 7min ago
     Docs: man:sshd(8)
           man:sshd_config(5)
  Process: 548 ExecStartPre=/usr/sbin/sshd -t (code=exited, status=0/SUCCESS)
 Main PID: 581 (sshd)
    Tasks: 1 (limit: 1935)
   CGroup: /system.slice/ssh.service
           └─581 /usr/sbin/sshd -D

Sep 22 09:29:43 worker systemd[1]: Starting OpenBSD Secure Shell server...
Sep 22 09:29:45 worker sshd[581]: Server listening on 0.0.0.0 port 22.
Sep 22 09:29:45 worker sshd[581]: Server listening on :: port 22.
Sep 22 09:29:45 worker systemd[1]: Started OpenBSD Secure Shell server.
$ service sshd status
● ssh.service - OpenBSD Secure Shell server
   Loaded: loaded (/lib/systemd/system/ssh.service; enabled; vendor preset: enab
   Active: active (running) since Thu 2022-09-22 09:29:45 BST; 9min ago
     Docs: man:sshd(8)
           man:sshd_config(5)
  Process: 548 ExecStartPre=/usr/sbin/sshd -t (code=exited, status=0/SUCCESS)
 Main PID: 581 (sshd)
    Tasks: 1 (limit: 1935)
   CGroup: /system.slice/ssh.service
           └─581 /usr/sbin/sshd -D

Sep 22 09:29:43 worker systemd[1]: Starting OpenBSD Secure Shell server...
Sep 22 09:29:45 worker sshd[581]: Server listening on 0.0.0.0 port 22.
Sep 22 09:29:45 worker sshd[581]: Server listening on :: port 22.
Sep 22 09:29:45 worker systemd[1]: Started OpenBSD Secure Shell server.

EDIT 2

The only solution is to flush the SD card each time I do a reboot. This will make it reachable via Putty and I think that it's not the better solution.

Need your help please. Any insight or guidance would be greatly appreciated. Thank you so much in advance.

New contributor
Doudda is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
5
  • Edit your question and tell us which machine you are tring to SSH from, the exact command used, the exact response, and whether you can ping the Pi from that machine.
    – joan
    Sep 22 at 11:17
  • Thank you for your interest. Updated the post as asked. Thanks again.
    – Doudda
    Sep 22 at 16:37
  • Please clarify your specific problem or provide additional details to highlight exactly what you need. As it's currently written, it's hard to tell exactly what you're asking.
    – Community Bot
    Sep 23 at 2:27
  • The solution seems pretty obvious. Something in the update didn't play nice with the ssh connection (or the pi OS itself). Go plug a monitor into the pi and reboot. That's likely the only way you are going to find out what the issue is. It may be a SD card issue, who knows. You will need to see what happens during boot and then if it does boot, you will need to login locally to troubleshoot the network issue. Having a dead box on the end of the line -- tells you nothing. If you remote-admin the box, find someone on-site that can be your eyes and hands. Sep 23 at 4:05
  • Let me google that for you: - try this. Lots more here. All for free.
    – Seamus
    Sep 23 at 15:10

1 Answer 1

0

Thank you for all your answers. I flushed the SD card and it works fine now. The only thing is that I mustn't do a reboot otherwise it will become unreachable again via Putty.

New contributor
Doudda is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.