0

Printer mainboard: BTT SKR mini E3 V3.0 running klipper firmware

https://github.com/bigtreetech/BIGTREETECH-SKR-mini-E3

Long story short, I accidentally powered on my 3D printer while unplugging the power cord. Since then it has been acting weird.

Going through the troubleshooting steps I've reached a point where I can't say if the printer mainboard is actually damaged or if it's a compatibility issue.

So, ASUS UX305CA laptop running Ubuntu 20.04 detects it ok, although sometimes after issuing klippers firmware restart it doesn't come back online before I unplug and reconnect the cable.

Pi 4 running MainsailOS, I think it was the latest version, doesn't detect it. Errors out in the dmesg.

Pi 3 running an older version of Raspbian Lite also errors out.

dmesg from Pi 3 Raspbian Lite:

[  142.606431] blk_update_request: I/O error, dev sda, sector 2049 op 0x1:(WRITE) flags 0x0 phys_seg 1 prio class 0
[  142.606471] Buffer I/O error on dev sda1, logical block 1, lost async page write
[  142.606526] blk_update_request: I/O error, dev sda, sector 34817 op 0x1:(WRITE) flags 0x0 phys_seg 1 prio class 0
[  142.606543] Buffer I/O error on dev sda1, logical block 32769, lost async page write
[  142.703408] FAT-fs (sda1): unable to read boot sector to mark fs as dirty

dmesg from Pi 4, running MainsailOS. This took a few tries of unplugging and plugging it back in to show up:

[  256.082940] hub 1-1:1.0: hub_ext_port_status failed (err = -71)
[  256.082961] usb 1-1-port2: Cannot enable. Maybe the USB cable is bad?
[  256.083218] usb 1-1-port2: cannot disable (err = -71)
[  256.084119] usb 1-1-port2: cannot reset (err = -71)
[  256.084368] usb 1-1-port2: cannot reset (err = -71)
[  256.084615] usb 1-1-port2: cannot reset (err = -71)
[  256.084864] usb 1-1-port2: cannot reset (err = -71)
[  256.085115] usb 1-1-port2: cannot reset (err = -71)
[  256.085145] usb 1-1-port2: Cannot enable. Maybe the USB cable is bad?
[  256.085364] usb 1-1-port2: cannot disable (err = -71)
[  256.085757] usb 1-1-port2: attempt power cycle
[  256.423166] usb 1-1-port2: cannot reset (err = -71)
[  256.423388] usb 1-1-port2: cannot reset (err = -71)
[  256.423636] usb 1-1-port2: cannot reset (err = -71)
[  256.423882] usb 1-1-port2: cannot reset (err = -71)
[  256.424130] usb 1-1-port2: cannot reset (err = -71)
[  256.424160] usb 1-1-port2: Cannot enable. Maybe the USB cable is bad?
[  256.424384] usb 1-1-port2: cannot disable (err = -71)
[  256.425226] usb 1-1-port2: cannot reset (err = -71)
[  256.425480] usb 1-1-port2: cannot reset (err = -71)
[  256.425739] usb 1-1-port2: cannot reset (err = -71)
[  256.425991] usb 1-1-port2: cannot reset (err = -71)
[  256.426248] usb 1-1-port2: cannot reset (err = -71)
[  256.426278] usb 1-1-port2: Cannot enable. Maybe the USB cable is bad?
[  256.426504] usb 1-1-port2: cannot disable (err = -71)
[  256.426896] usb 1-1-port2: unable to enumerate USB device
[  256.427131] usb 1-1-port2: cannot disable (err = -71)
[  256.427980] usb 1-1: Failed to suspend device, error -71

And for comparisons sake, dmesg from the laptop, which showed up immediately on first try:

[23728.229748] usb 1-1: new full-speed USB device number 5 using xhci_hcd
[23728.379513] usb 1-1: New USB device found, idVendor=1d50, idProduct=614e, bcdDevice= 1.00
[23728.379523] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[23728.379529] usb 1-1: Product: stm32g0b1xx
[23728.379533] usb 1-1: Manufacturer: Klipper
[23728.379536] usb 1-1: SerialNumber: 10004C000450414235363020
[23728.381195] cdc_acm 1-1:1.0: ttyACM1: USB ACM device

I'm using the same cable on all 3 devices. The cable came with the printer mainboard and I'm 99.99% sure that it's fine, as it was working for weeks before this. I have tried another, longer cable, but it didn't change anything for the better. I've also tried every port on the Raspberrys and confirmed them working with a kingston usb stick that reports fine in dmesg.

It's also able to start and finish a print when using the laptop.

New contributor
user149248 is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
4
  • When something works on one device and not another over USB, it is either insufficient power (try a powered USB hub) on the USB line or a driver issue.
    – Abel
    Sep 22 at 12:23
  • To clarify, it worked fine on both of the Raspberries for weeks with the exact same setup. The printer mainboard has its own psu. I'm trying to figure out whether this is now a hardware issue after the unplug accident or a software issue caused by updates to the linux system.
    – user149248
    Sep 22 at 18:42
  • Your unplug accident may have caused the printer onboard supply to stop powering it's 5V rail. Your updates may have caused the os to no longer reach for your previously working driver's. Try supplying 5V power at least equivalent to what the working laptop provides or running the image that worked.
    – Abel
    Sep 22 at 18:47
  • The printer mainboard gets 24 V supply from the printer's psu. It does not use 5V power from the usb, in fact there's a jumper on the board to prevent this.
    – user149248
    Sep 23 at 7:33

0

Your Answer

user149248 is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.