1

Context: I am running the 32bit full Raspbian OS on the raspberry pi 4 as a desktop, the newest version. Whenever I open chromium, the default web browser, it simply opens a window. When I tried to open that window, it would open briefly and disappear. Similarly, I'm getting this type of action with Mu, a default python IDE for raspberry. I thought this could've been an issue with all my apps on my PI, but when I tried running some generic default games, they seemed to work fine.

My Troubleshooting: I've had chromium working previously, but now it's not working. I've checked all updates and upgrades. This hasn't led me anywhere. I've tried almost every way to update chromium . I then resorted to deleting the browser via purging it from the system. I then tried to redownload, issues downloading.

After purging chromium, I get a new default browser, firefox. When I try to open firefox, it just completely shuts down my entire system.

My team and I are noobs with Linux and raspberry Pi, so if you have a potential solution, please make it such that we can follow along like the copy and pasting wizards we've become.

Posted below is a pdf document of some of the code we tried, and what the console has given us in response. Weve been at this for a month and cannot find an answer.

PS We already tried rebooting the raspberry pi and reflashing the pi with a new os. We don't want to do that again since we have downloads we want to keep. We are running raspbian os and we have the raspberry pi 4; 2 GB

Thanks in advance!

1 Answer 1

0

You need to search for the error log created by the programs when they fail to start. The errors will indicate the problem.

If they don't create an error log there may be a command line option to switch logging on for the program.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.