0

Here is a weird one for yall. I kinda busted my OS up and I want to reflash a headless install of the Raspberry Pi OS. I spent literally hours as I take the micro SD card off and I put it in my MS-windows 10 PC. I tried etcher, reflashing, reformatting, diskpart, official imager, and they all said it is read only. Furthermore, searching online results people saying that the micro sd card is DEAD and that the read only thing protects the data left.

So there I thought: welp, there goes ol' sandisk, time to buy a new one, but WAIT, I plug it back inside the raspberry pi and the micro SD card works PERFECTLY. I can do vi file.txt I can do batch-write operations etc. Why is windows lying to me that the sd card is write only? Keep in mind again, I have used a multitude of tools that I pretty much exhausted.

NONE of them worked and I was one second away to throwing the micro SD card in the trash until I plugged it back in to the Pi, for it to ONLY work on the pi. Why won't it let me reflash a new image? Please help.

Edit: tried it on several computers just to make sure the SD card readeer wasnt faulty. So that adds to the strangeness.

3
  • 1
    windows does not understand the file system on the SD card
    – jsotola
    Sep 30, 2022 at 5:37
  • If you are using a micro SD -> SD adapter, check it does not have a little read-only slide switch on it.
    – goldilocks
    Sep 30, 2022 at 15:15
  • @goldilocks It is not locked, I have made sure that by flipping the switch UPWARDS.
    – VJZ
    Oct 1, 2022 at 0:04

1 Answer 1

1

Windows... ugh! My last experience was with Windows 7, so this may or may not work, but:

I've used rufus successfully on my old Windows 7 box, and AFAIK it works on the latest versions of Windows as well. IMHO, rufus is competent software.

WRT your SD card being read-only: As you probably know, SD cards are subject to a wear-out mechanism - they all fail eventually. The SD controller that's built into the card's electronics performs a "wear-leveling" process that helps extend the life. I've read that when the "wear-leveling" process has reached its limit, the SD controller will disallow writing - effectively making the card a read-only unit from that point forward. If that's what's happened to your card, there's nothing to be done except replace it.

However, the fact that your RPi still mounts the SD card RW suggests that the problem you're seeing may be a "false alarm" due to some fault in Windows. I can't comment on Windows issues, but you may wish to research that possibility - or ask your question in another forum. I would say that if rufus cannot write to your SD card, you may in fact have a potential issue with the card.

Finally, your best defense against such issues is to 1. Keep a current backup, and 2. Keep a spare SD card.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.