I have a raspberry pi 4b, which has been booting happily off an external usb-connected ssd. I have now put it into an Argon ONe case, with an MD SSD, and it will not recognise the M2 drive at all as a block device.

lsusb -t shows two mass storage devices on the usb interface:

/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/4p, 5000M
    |__ Port 1: Dev 2, If 0, Class=Mass Storage, Driver=uas, 5000M
    |__ Port 2: Dev 3, If 0, Class=Mass Storage, Driver=usb-storage, 5000M

Device 03 is the new drive. Device 02 is the old drive, which works.

I can see from this that they have different drivers, and I suppose that must have something to do with the problem. But how can I solve it? Can I force the use of the uas driver, if that is the one that works?

  • 2
    Please do not add "SOLVED" to a question title. After 24h, you should be able to green tick your own answer. Please also take the tour to understand better how the site works.
    – goldilocks
    Oct 6, 2022 at 13:40

1 Answer 1


Solved. It turns out the problem was — for once — insufficient force applied. I needed to shove the ssd into its slot so hard that it clicked, like a stick of ram. After that everything was fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.