3

I can access from my PC to eth0.10 (vlan 10) but when I want to access to eth0.20 vlan 20 I can't access

my operating system is Debian this is the interfaces of my raspberry pi

auto lo

iface lo inet loopback

auto eth0

iface eth0 inet static

address 192.168.1.2

netmask 255.255.255.0

gateway 192.168.1.1


auto eth0.10

iface eth0.10 inet static

        address 192.168.10.2

        netmask 255.255.255.0

        network 192.168.10.0

        broadcast 192.168.10.255

        gateway 192.168.10.1

        vlan-raw-device eth0


auto eth0.20

iface eth0.20 inet static

        iface eth0.20 inet static

        address 192.168.20.2

        netmask 255.255.255.0

        network 192.168.20.0

        broadcast 192.168.20.255

        gateway 192.168.20.1

        vlan-raw-device eth0

this the routing table

Kernel IP routing table

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface

0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 eth0

192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0

192.168.10.0    0.0.0.0         255.255.255.0   U     0      0        0 eth0.10

192.168.20.0    0.0.0.0         255.255.255.0   U     0      0        0 eth0.20
  • 1
    Please give us the output from "ifconfig -a" and "cat /proc/net/vlan/config". – Marco Poli Jul 11 '14 at 3:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.