I have a Model B with 2 USB ports. From what I can tell this is the very first version. See picture below from when it was functioning long ago.

It was last used in 2014 with a then-current version of Raspbian, but I lost the memory card.

I recently tried to revive it so I bought a new memory card (SD adapter with 32 Gb micro-SD), downloaded and installed the current version of Raspberry Pi OS, and tried to boot up.

On the first boot, there was a message about generating SSH keys (I chose not to do that when creating the boot image).

Then a black screen with the Raspberry Pi logo and some file names passing by written below it. Looks like a normal boot. This goes on for 10-30 seconds. Then the monitor goes black, saying "no signal" as if the PI stopped sending video, and if I wait a couple of minutes, the PI reboots most of the time, repeating these things except the SSH part. Sometimes it just stays black.

I thought there might be some incompatibility between the newest OS and the oldest PI, but are there any other "obvious" suggestions than trying an older/lightweight OS?

I saw this thread which is somewhat related but not a duplicate:

Lightweight OS for original Raspberry Pi Model B?

Also saw this post suggesting to move mouse/press keyboard, which does not help in my case My raspberry pi 2 model B boots but then the screen turns black

enter image description here

2 Answers 2


I installed Legacy on the SD card and this works. Had some video problems which were surprisingly solved by enabling overscan (which was disabled), contrary to all suggestions I found.


You provide very little info.

My guess would be an issue with your (unspecified) monitor. You might try some of the display settings in https://www.raspberrypi.com/documentation/computers/config_txt.html#hdmi-mode

Raspberry Pi OS SHOULD work on all Pi (I haven't tried on a model B). Bullseye introduced some quite significant changes - particularly KMS which is configured differently to older models.

You might be better to try Legacy https://www.raspberrypi.com/news/new-old-functionality-with-raspberry-pi-os-legacy/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.