0

I tried to mount window shared folder on raspberry pi but it is not successful yet. Every time I run the command to mount, it just keeps showing mount error:Host is down.

Here is what I have tried to achieve mount shared folder on Pi

First, I get the window shared folder. In my case, it is

\\100.179.180.90\MyShare\TempFolder
Username =<USER>
Password =<Pass>

Then, I start to use this command in pi.

sudo mount -t cifs -o username=<USER> //100.179.180.90/MyShare/TempFolder /media/mountName

However, I have got this error.

mount error(112): Host is down
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Then I edit .smbcredentials using sudo nano ~/.smbcredentials

username=<USER>
password=<Pass>

and fstab using sudo nano /etc/fstab.

//100.179.180.90/MyShare/TempFolder /media/mountName cifs credentials=/home/pi/.smbcredentials,uid=1000,gid=1000,vers=3.0,nounix 0 0

Then I put sudo mount -a then the error is still the same.

Host is down.

But then when I check FileManager,

mount: /media/mountName: operation permitted for root only.

Even though I use /mnt/test it keeps showing me error of host is down.

I have used different versions of SMB protocols stated in pi documentation. For example,

sudo mount.cifs //100.179.180.90/MyShare/TempFolder /mnt/test -o user=<USER>,vers=3
Password for CIM_ADMIN@//100.179.180.90/MyuShare/TempFolder:

I thought it is root access issue but I am not sure. I can ping the ipaddress(100.179.180.90) from (\\100.179.180.90\MyShare\TempFolder)) from pi and it works. But mounting window shared folder is giving me headache.

5
  • How did you mount? What are you mounting?
    – Milliways
    Oct 12, 2022 at 1:54
  • I am mounting a window shared folder on raspberry pi. I followed this article(askubuntu.com/questions/1341844/…)
    – MyatKaung
    Oct 12, 2022 at 2:06
  • Are you using Ubuntu? if so specify in tags. When I asked how i meant WHAT YOU DID - not a link (especially a very poor post like this). There are LOTS of Questions on this site about mounting a Samba share.
    – Milliways
    Oct 12, 2022 at 2:11
  • DO NOT try to mount in /media which is used for automount use normal /mnt (or a dedicated directory.
    – Milliways
    Oct 12, 2022 at 2:13
  • Ok thanks so I am using Debian. And I put in sudo mount -t cifs -o username=User //100.180.130.25/TempShare/MyFolder /media/mountName. This is what I did and found that the error is host is down. So I check in file manager and I saw that it is for root only. I will update the question again as I think I need to write what I did to get the shared drive and got errors.
    – MyatKaung
    Oct 12, 2022 at 2:19

1 Answer 1

0

For example I use sudo mount.cifs //Milliways.local/Images /mnt/Image -o user=ian to mount a share on my Pi (for user ian).

I can't comment on Windows. See Samba (SMB/CIFS)

3
  • Thank you. Just a quick check. User should be the window username right?
    – MyatKaung
    Oct 12, 2022 at 2:23
  • I have used different versions of SMB protocols stated in pi documentation but the error still persists.
    – MyatKaung
    Oct 12, 2022 at 4:48
  • @MyatKaung User can be the username of any account that has access to your share. Linux usernames are case sensitive. You may (depending on your config) have to set an account password to authenticate, or change network profile/security policy to allow access with a blank password.
    – svin83
    Nov 11, 2022 at 11:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.