3

help me guys, im really desperate :( my RPi out of sudden stopped booting whenever i plug in the power cable it only turns on the red led! nothing more than that.. i've checked this site to troubleshoot it, inserted the SD card in my pc card reader , did a format and wrote a raspbian image on it but still no boot! what's the problem here?! need a new SD card? or a new raspberry :( ?

  • Does the green LED glow faintly? And have you tried a different power supply? – Wilf Feb 25 '14 at 13:20
2

When only the red led lights, it usually indicates there's no boot record on the SD card. If you are certain you created the new image correctly, make sure it is firmly inserted. I had one Pi where I had to hold the SD card firmly against the contacts for it to boot correctly.

  • i'm sure that i created the image correctly and tried to hold the SDcard firmly but still no result.. :( does that mean that it's corrupted? i'm having a hard time understanding that specially that i can access it from my pc – DieDen Feb 25 '14 at 0:45
  • 1
    @DieDen Can you SHA-1 the image? Sometimes the image file gets slightly corrupted during the download, a network glitch or something. You can grab the official SHA-1 checksum from the Raspberry Pi download page and you can download a Windows file that checks file integrity here and learn how to do it on Mac here – RPiAwesomeness Feb 25 '14 at 16:42
  • @RPiAwesomeness i had raspbian wheezy working fine on my RPi and the issue that i described above happened out of sudden..i did the checksum but it's different because the release that i have downloaded on my pc & rpi too is older than the one on the website.. anyway i'm downloading the latest release and crossing fingers to work on my sd card – DieDen Feb 25 '14 at 20:43
1

I've downloaded the latest version of wheezy, did the same old steps and it worked out! i frankly don't know how or even why it's got broken in the first place.. I'm just glad that it worked out finally and hoping to maintain this state. thanks for your responses guys

  • 1
    Welcome to a sad truth of the Raspberry Pi. SD cards can become easily corrupted, especially in case of a sudden loss of power – nagyben Feb 26 '14 at 0:03
  • And under powered usb power supplies. I had exactly the same problem, until I bought a dedicated Pi specified USB mains power supply. – rob Feb 26 '14 at 8:53
  • @rob I don't know if it's because of the power supply :/ but i was running raspberry on 1.2 A power supply just fine with both wifi adapter & arduino connected. when the error above happened it was just RPi running with no extensions. anyway i'm glad that it worked out :) – DieDen Feb 26 '14 at 14:15
1

I had a similar issue only red coming on and occasionally i could get it to boot, which indicated it wasn't corrupt..

I found my SD card was a bit loose and not making good contact with the pins. I used a strip of thin plasticcard on top of the SD card to make a really tight fit. Seemed to do the trick.

0

I found the B+ model to be a bit annoying in the way the micro sd cart is placed... when you push it up against something (i.e. a Lego case you build) it might release itself.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.