I have a problem concerning my raspberry pi camera version 2.1. The camera is supported, enabled but is not detected. I'm working with a Raspberry pi 3B+. I'm certain that I have plugged in my camera correctly. Sadly the other posts about this problem didn't really help me. Here is what I have tried out so far.

With sudo raspi-config under interfaces I enabled Legacy Camera. It gave me the following output:

Please note that this functionality is deprecated and will not be supported for future development

eventhough I'm currently using the earliest version of bullseye. I have also rebooted the raspberry many times in addition to using the commands sudo apt-get upgrade, sudo apt-get update.

I get the following output when entering the command:

pi@raspberrypi:~ $ vcgencmd get_camera
supported=1 detected=0, libcamera interfaces=1

I get the following error when entering this command:

pi@raspberrypi:~ $ libcamera-still -o test.jpg
libEGL warning: DRI2: failed to authenticate
Made X/EGL preview window
[0:09:35.012274801] [1547]  INFO Camera camera_manager.cpp:293 libcamera v0.0.1+21-7c855784
ERROR: *** no cameras available ***

When entering the following I get: (I have changed this accordingly to the advice from https://forums.raspberrypi.com/viewtopic.php?p=1958297

pi@raspberrypi:~ $ cd /boot
pi@raspberrypi:~ $ sudo vi config.txt

1 Answer 1


I had the same problem. Raspberry pi 4b 8gb. I reinstalled my os this time using the old Legacy operating system (debian buster) from the raspberry imager. After that camera worked out of the box. I only had to enable it with raspconfig.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.