2

I have a problem, I'm using a wifi adapter TL-WN725N. On the display when scanning, it says "No Wireless Interfaces Found".

I've used the solution from the website: https://gist.github.com/MBing/de297a8ae5e8a191c55a67a568d20d31

But, it's failed.

I want to use the solution from: http://downloads.fars-robotics.net/wifi-drivers/8188eu-drivers/

But, my kernel is not available.

My kernel:

Linux raspberrypi 5.10.63-v7+ #1496 SMP Wed Dec 1 15:58:11 GMT 2021 armv7l GNU/Linux

My OS Version:

PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"

enter image description here

When I do ifconfig, the wifi adapter can detect:

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.100.1  netmask 255.255.255.0  broadcast 192.168.100.255
        inet6 fe80::a19d:4bb7:cbb8:7252  prefixlen 64  scopeid 0x20<link>
        ether b8:27:eb:45:d5:4a  txqueuelen 1000  (Ethernet)
        RX packets 6683  bytes 907655 (886.3 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 2714  bytes 487448 (476.0 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 952  bytes 83318 (81.3 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 952  bytes 83318 (81.3 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 9c:a2:f4:70:fb:f0  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

WiFi adapter can also scan using iwlist.

$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     unassociated  ESSID:""  Nickname:"<WIFI@REALTEK>"
          Mode:Auto  Frequency=2.412 GHz  Access Point: Not-Associated   
          Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

wpa_supplicant.conf settinf

$cat /etc/wpa_supplicant/wpa_supplicant.conf

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=ID

network={
        ssid="MY_WIFI"
        psk="1234567890"
        key_mgmt=WPA-PSK
}

However, when connecting to a WiFi Client (using wpa_supplicant.conf). Communication not connected. What's Happen?

7
  • How do you expect it to work if "But, my kernel is not available.". If you are going to compile your own driver then you need the kernel headers for your kernel version.
    – MatsK
    Nov 7, 2022 at 8:53
  • You have listed problems, linked to obsolete "solutions" but failed to mention what you have installed. ifconfig is deprecated and iwlist will only show connected networks. ls /sys/class/net will be show available network devices. You OBVIOUSLY have a wireless interface because wlan0 is shown.
    – Milliways
    Nov 7, 2022 at 8:53
  • @MatsK I hope there is a new solution to the problem that I describe.
    – renaldyks
    Nov 7, 2022 at 9:02
  • @Milliways That's right, it looks like wlan0 is detected on the system. But, why when doing WiFi client mode, my WiFi adapter can't connect?
    – renaldyks
    Nov 7, 2022 at 9:04
  • @Milliways I've revised, that's what I mean
    – renaldyks
    Nov 7, 2022 at 9:19

2 Answers 2

2

I also encountered this problem on a new image with the configuration below. The GUI shows "No wireless interfaces found", while at the same time, the usb wifi adapter already has working drivers and firmware included in the raspios image. The wlan0 interface is also working via ifconfig and iwlist.

  • Raspberry Pi 2 v1.1 BCM2836
  • New image of 2022-09-22-raspios-bullseye-armhf-full.img
  • USB Realtek Semiconductor Corp. RTL8188EUS 802.11n Wireless Network Adapter

enter image description here

The solution is to:

  1. Run sudo raspi-config
  2. Choose 6 Advanced Options
  3. Choose AA Network Config
  4. And set Select the network configuration to use to 2 NetworkManager
  5. Exit and reboot.

The GUI can now be used to associate with access points.

enter image description here

0

cat /etc/wpa_supplicant/wpa_supplicant.conf

Normally shows Permission denied.

Either you are typing something else or have done something wrong.

It is unclear WHY you are trying to enter this manually; it is created when you run the GUI.

If you REALLY want to manually set wpa_supplicant.conf put it in the boot partition and reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.