0

In past I was using VNC and it worked well. Now, I want to abandon RealVNC and switch to xrdp. I have spent several hours trying to get the xrdp to work. I have went through several suggestions found with Google. Many of those are obviously wrong and too exotic to work. I am new RPI user and have concern that some of these trials have permanently messed my system.

I would like to see less than 10 sudo commands to be applied to a new SD card to make the xrdp connection. Where I can find the solution?

2
  • you are using a linux computer ... your question belongs at unix.stackexchange.com/questions
    – jsotola
    Commented Nov 17, 2022 at 6:35
  • There is the potential for confusion between commands to install Raspberry Pi software on a new SD card and commands to run when that SD card has booted on a Raspberry Pi. In addition, to use the RPi xrdp server, another system must have a RDP client installed. ps: Don''t forget about firewalls. Commented Nov 17, 2022 at 20:20

1 Answer 1

1

First link when searching for "raspberry pi xrdp" is this

Relevant instructions

sudo apt install xrdp 
sudo adduser xrdp ssl-cert

tested and working on pi3b+ running Bullseye (aarch64)

OK, for 64bit on Raspberry Pi 4 there is one more step

as seen here

Edit /etc/X11/xrdp/xorg.conf and set

Option "DRMDevice" ""

This disables glamor for xrdp session only.

6
  • I did try that sequence. When I did use my own password for user "pi", the end result was an empty blue screen. When I did change the password back to "raspberry", I still got the blue screen, but this time with a dialog giving me an error message. There could be a difference between RPI3B+ and RPI4B.
    – Ollie
    Commented Nov 17, 2022 at 1:38
  • Thanks for a rapid reply. I have been doing the testing with two different RPI4 boards with same results. Some of the hints in internet are recommending to add a new user account just for the xrdp. That should resolve the issue of forced use of the default password.
    – Ollie
    Commented Nov 17, 2022 at 1:46
  • At the end, I do guess that I will realize what kind of newbie errors I have made. I have done several fresh installs with 32 bit and 64 bit PI OS, The results are still the same. At the same time, I can observe that there are large number of other users who are wrestling with this same problem. Just for checking, what are the exact user id and password you have given in the Raspberry PI imager.
    – Ollie
    Commented Nov 17, 2022 at 2:27
  • I did a fresh install with pi/raspberry and used the two sudo commands you did show. The end result was the same empty blue screen. If it seems to you that I am the only one struggling, please don't reply.
    – Ollie
    Commented Nov 17, 2022 at 4:53
  • 1
    @Ollie - updated answer despite your rude attitude Commented Nov 17, 2022 at 5:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.