I am trying to connect to an Raspberry Pi Pico from an Raspberry Pi 3B+ running Raspian Bullseye. The Pico shows up in the File Manager when I connect with the BOOTSEL button pressed. When I try to install the MicroPython interpreter via the Thonny Interpreter Configuration dialogue it appears to work. I get the 'Done!' message and looking at the dialogue that appears when you click Done I see the following:

Waiting for the port
Found 2e8a:0005 at /dev/ttyACM0

That seems to indicate that the firmware install worked, but I don't see any REPL prompt in Thonny and I get:

Backend terminated or disconnected. Use 'Stop/Restart' to restart.

But 'Stop/Restart' doesn't do anything, nor do any of the other Thonny commands.

I have tried to flash both the MicroPython_RenameMainDotPy.uf2 file and the flash_nuke.uf2 file, but neither makes any difference, and I typically get an error saying An operation is already pending and I haven't found any way to clear this seemingly blocked operation.

I have tried two Picos, with the same results for both. Both Picos were working fine a few months ago, and the only thing I have done in the meantime is an apt update followed by an apt upgrade. Apt tells me that Thonny is the latest version when I try to upgrade it.

UPDATE: The above is incorrect, I did upgrade from Raspbian Buster to Bullseye some months ago on the Raspberry Pi host. That may well have something to do with it. I had forgotten that.

I also thought it might be a bad USB cable, but I have tried 3 or 4 different cables with exactly the same results.

This is extremely frustrating. Does anyone know what the problem might be?

NEW UPDATE: I tried the Pico on an RPi 4 also running bullseye and REPL in Thonny works fine on that host after flashing the MicroPython interpreter. The only difference between that and my RPi 3B+ is that I did an apt update followed by apt upgrade two days ago on the 3B+. It seems that quite a bit was upgraded as connman was installed on the 3B+, but it wasn't on the model 4B. So, something got updated/upgraded recently that is blocking proper connection with the Pico.


1 Answer 1


SOLVED: Enabling the serial port in raspbi-config resolved the problem. I can now access the Pico through the new port marked

    Board in FS mode - Board CDC (/dev/ttyACM0) 

However, on my RPi 4B the serial port was not enabled and I was still able to access the micropython REPL prompt.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.