1

The Pi version of Minecraft comes as an executable. I downloaded Minecraft on a Mac, copied it to a micro-SD, then copied it to the Pi. Every time I try to run the executable it says "permission denied". Even when I use sudo it says that. When I use chmod +x it says nothing, but it won't run. How do I fix this?

  • 1
    What OS are you running? Why didn't you just download Minecraft for the Pi directly on your Pi? Perhaps you don't have an executable compiled for ARM? – HeatfanJohn Feb 26 '14 at 14:21
  • What Raspberry Pi OS are you running (Raspbian, Pidora, Arch for ARMv6)? If you are on Raspbian try running sudo chmod +rwx -R ~/mcpi && sudo chown pi -R ~/mcpi. You can run this from anywhere, and, if you have a different user than the default pi one, swap out your username for USER in +rwx USER and chown USER. This will give your user full read, write, and execute permissions AND make sure you own the files. – RPiAwesomeness Feb 26 '14 at 18:14
  • @HeatfanJohn I was unable to connect to wifi, so I had no way to download it. – Arc676 Mar 4 '14 at 9:21
  • 1
    @RPiAwesomeness I didn't find the "About" section, but the command worked, so apparently the OS was Raspbian (I didn't know because it was a public Pi from a group of computer enthusiasts, not mine) – Arc676 Mar 4 '14 at 9:22
  • @Arc676 Glad you resolved your issue! I've created a full answer below, if you could mark it as such, it would be really great, as it helps keep up the site's stats and gets us closer to graduation to being a full Stack Exchange site. Also, if you plan on being involved in this community try popping into the chat occasionally. We always love a little company and it helps grow community. – RPiAwesomeness Mar 4 '14 at 14:26
1

This is an answer for this question that was solved in the comments. Basically, the permissions weren't correct for the minecraft-pi executable, probably because of permissions from where the minecraft-pi executable was downloaded from.

This is how to fix it:

  1. Download Minecraft Pi either via $ wget https://s3.amazonaws.com/assets.minecraft.net/pi/minecraft-pi-0.1.1.tar.gz
  2. Extract the minecraft-pi tarball via tar -zxvf minecraft-pi-0.1.1.tar.gz
  3. Run sudo chmod +rwx -R ~/mcpi && sudo chown pi -R ~/mcpi
  4. cd into the mcpi folder via cd ~/mcpi
  5. From within the mcpi folder run ./minecraft-pi and Minecraft Pi should start up!

Have fun!

1

Try running the command:

 file ./minecraft-pi

Where ./minecraft-pi is the executable command that you are trying to run that returns permission denied. This command should display something like this below which is the output I get on my Pi.

./minecraft-pi: ELF 32-bit LSB executable, ARM, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.26, BuildID[sha1]=0x7f5a7cece83092451a55d83790b260ab639e59e9, stripped

I vaguely recall getting permission denied errors when trying to run an exectable that was built for a different processing environment.

1

sudo chmod +rwx -R ~/mcpi && sudo chown pi -R ~/mcpi fixed it.
Steps:
1. Download Minecraft Pi
1a. Save it somewhere on a Pi
2. Type the above command into LXTerminal
3. Use cd to enter the folder containing the executable
4. Type ./minecraft-pi

Thanks @RPiAwesomeness

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.