1

I am attempting to create a Raspberry Pi 4 NAS setup.

I purchased two Seagate Ironwolf 125 1TB SSD USB (pdf warning) disks.

The trouble that I am having is that the RPI will not always recognize the hard drives. When I first initialize the RPI via the Raspberry PI Imager and have the disk drives attached via the USB 3 ports, the RPI will USUALLY find the drives and I am able to interact with them and make new directories and move files onto the disks.

However, after some time, the drives are no longer accessible and are not accessible after reboots either. Meaning the disks are no longer even found by the RPI though the lsblk, blkid, or fdisk commands.

I am concerned that the RPI doesn't have enough power to properly power these two disks.

How do I go about debugging this problem?

Any friendly advice/suggestions would be greatly appreciated.

Side Notes and Observations

The drives themselves are SATA, I purchased two different types of USB 3.0 to SATA cables: StarTech.com SATA to USB Cable - USB 3.0 to 2.5” SATA III Hard Drive Adapter and UCTRONICS SATA to USB 3.0 Adapter Cable for 2.5 Inch SSD SATA III Hard Drive Disk Converter.

The drives actually are warm to the touch when connected to the RPI, so, they must be getting at least some power from the RPI.

I connected both ssds to my windows machine and both drives were recognized by Seagate's SeaTools application. I tested both drives and they both passed the Short Self Test, Long Self Test, and 2 Minute Generic Test.

Edit 1

sudo dmesg output

There was very little of interest in that output. But these messages did come up associated with usb.

[    0.168130] usb_phy_generic phy: supply vcc not found, using dummy regulator
[    0.168329] usb_phy_generic phy: dummy supplies not allowed for exclusive requests
8
  • when the drives become no longer accessible, is there any error in the output of dmesg to suggest an issue? Dec 4, 2022 at 20:44
  • @JaromandaX thank you for your comment. I didn't see anything to exciting in the sudo dmesg output. I did add what I thought could be interesting to the question.
    – hooknc
    Dec 6, 2022 at 0:57
  • Could you clarify - are these USB external drives as manufactured? I thought the Ironwolf 125 was a SATA drive designed for NAS use. Are you using USB to SATA adapters? Dec 8, 2022 at 19:05
  • @MichaelHarvey, The drives themselves are SATA, I purchased two different types of USB 3.0 to SATA cables: StarTech.com SATA to USB Cable - USB 3.0 to 2.5” SATA III Hard Drive Adapter and UCTRONICS SATA to USB 3.0 Adapter Cable for 2.5 Inch SSD SATA III Hard Drive Disk Converter.
    – hooknc
    Dec 10, 2022 at 15:25
  • The total power draw over all USB outlets on the Pi is 1.2A. If you exceed that, even momentarily, you'll get issues, file system corruption, un-mounting, etc. Can you confirm these 2 drives are both connected to the Pi's USB and getting power that way? And no other devices? Also it is possible that the 2 drives (2 x 480 mA = 960 mA) plus the power the adapters also need (can't find any figures) may take you over the 1200 mA limit at times. You only need a bit over 120 mA per adapter to do that. I presume you have tried one drive at a time? Dec 10, 2022 at 15:57

3 Answers 3

0

There is a sticky on USB storage at the official Rpi forum (which is often worth visiting!). Also you could try posting there.

STICKY: If you have a Raspberry Pi 4 and are getting bad speeds transferring data to/from USB3.0 SSDs, read this ... We have seen reports of extremely degraded performance when using several types of USB3.0 to SSD adapter or when using native USB3.0 disk drives. This post details why there is a difference in behaviour from models prior to Pi 4 and the recommended workaround. –

Sticky on this subject at Rpi Forum

0

After a significant amount of futzing and a lucky catch a term to search on out of the corner of my eye, I believe that the problem is actually with how the RPI and Seagate Ironwolf drives play (or better, don't play) together.

I ran across this post: Seagate IronWolf 125 support

That post summarizes to

The cache of the drive fills up and the drive gets bricked...

I then tried the Seagate SeaTools application and did the "Fix All -> Long" option and now the drives are recognized by my RPI again.

My solution is going to be the following:

  • Continue my support request with Seagate to see if there is a long term fix for this issue for linux machines with arm processors (like our RPIs).
  • Purchase some of the Kingston A400 ssd drives and test those out instead.

It is a shame that the Seagate IronWolf drives aren't working out very well since I am building a nas, I really wanted nas rated drives. But, that is part of the price of tinkering and trying to build a nas instead of purchasing a nas.

-1

They draw max 2.4W each and that is 480mA each, and that is close to 500mA max for a USB hub, and then you have two, so it's too much load for a USB hub.

There is lsusb -v|egrep "^Bus|MaxPower" that shows the current consumption that could give you a clue.

5
  • Excellent, thank you for your post. I will try that out shortly. I am currently experiencing a different problem where the RPI4 will boot on a fresh os image, but then shuts down without explanation. Yay?
    – hooknc
    Dec 8, 2022 at 18:26
  • According to that command, my Western Digital USB HDD is drawing 896 mA. It has been attached and in use for 2 years. Dec 8, 2022 at 19:51
  • And they are on separate USB bridges?
    – MatsK
    Dec 13, 2022 at 18:50
  • While USB devices MAY request power the Pi has no mechanism to honour these requests. You can draw 1200mA from USB, even from a single port.
    – Milliways
    Jan 29, 2023 at 0:30
  • OK, I didn't know that the USB bridge in the RPi didn't follow the USB spec.
    – MatsK
    Jan 29, 2023 at 15:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.