1

I'm having some wifi Issues with Bullseye / BrosTrend AC1200 / Le Potato 1gb.

I figure my problem is more related to Raspberry OS / my adapter than my board, but I could totally be wrong here.

The Background

Here's where things are at

  • Flashed a clean/uncompressed RPI OS 11 Bullseye from Libre's website onto SD as per the guide

  • During setup, I forgot that I had a cheap wifi adapter plugged into my Le Pot / no ethernet. The Pi OS setup spotted my SSID out of the box with that cheap adapter, I tried to connect, but it failed to connect. I chalked it up to the crappy adapter, plugged in my ethernet, and unplugged the adapter. The only reason I mention it is maybe some weird config things happened here.

  • I continued setup, got to the desktop, chromium installed, and bam I'm browsing the internet with zero problems on ethernet.

  • I then plug in my BrosTrend AC1200 (AC1L) adapter, unplug the ethernet, and find my adapter is not immediately recognized out of the box.

  • Ethernet back in, download the drivers via their official guide, namely:

    sh -c 'wget deb.trendtechcn.com/install -O /tmp/install && sh /tmp/install'

  • Rebooted, took out ethernet. Sure enough, the wifi can scan for SSIDs and connect to my SSID.

The Problem However, here is the problem: without fail my pi will stop communicating ALL network traffic within minutes. When I try to ping 8.8.8.8 or even any local devices on my network, I only receive Destination Host Unreachable. I've searched the common options such as

  • making sure wifi power management is off (it is)

  • double-checking I'm not forcing a static IP in /etc/dhcpcd.conf

  • alternatively have tried forcing a static IP

  • changing my nameservers from my router IP to 8.8.8.8 in resolv.conf

  • tried alternatives such as network-manager

  • tried using a powered USB hub

  • checked in my router's list to ensure IP is accurate and given via dhcp

  • added freq_list to limit to 2.4ghz in wpa_supplicant.conf (unsure if this is working, I read some reports that the pi (and maybe, therefore, a potato) didn't like 5ghz band)

this is required because I use a google wifi router (just one, no mesh) with a combined 2.4/5ghz. Additionally, I'm working on an IOT concept device that would need to be plug and play with any network

  • I've also heard that setting your Wifi Country to something like Israel or China can force it to not scan for 5ghz wifi? Haven't tried that

  • Wifi country is set to US in wpa_supplicant and looks identical to ones I've seen on other posts as far as "what is correct"

None of these have solved it. With ethernet in, I'm steady as she goes.. But on the wifi card, it displays as connected in the UI but I only receive Destination Host Unreachable when pinging anything.

Hardware Summary:

Libre Computers Le Potato AML-905X-CC

BrosTrend AC1L / AC1200 Wifi Adapter

Raspberry OS 11 Bullseye Stretch via Libre port

--

Please let me know if you have any ideas of what could be going on here.

I'm happy to dump copies of .confs or whatever if you have any suggestions as far as where to look next!

TIA

5
  • Which model raspberry pi is it? at a guess, the wifi adapter is hot garbage, or maybe it's just going to sleep and not waking up Dec 12, 2022 at 22:18
  • I read some reports that the pi didn't like 5ghz band - even if that were the case, what would an issue (that I've never heard of) with pi's onboard wifi have to do with a USB wifi dongle on a potato? Dec 12, 2022 at 22:22
  • @JaromandaX it's a Libre Computers Le Potato 1gb (pi knockoff). The BrosTrend AC1L was the best reviewed adapter I could find in my price range for linux systems. It should not be going to sleep as I've ensured all wifi power saving modes are off each boot. Furthermore, I've just been trying fixes that appear in other threads to see if it helps. I have no proof about the 5ghz issue, no need to be on the offensive on that for my list of random things I've attempted.
    – Jay Noe
    Dec 12, 2022 at 22:26
  • on the offensive? what are you on about? I was simply saying the even if there were an issue with the raspebrry pi onboard wifi, that would have nothing to do with a wifi dongle, and absolutely nothing to do with something that isn't even a pi - have you checked the system logs when the wifi goes down for any errors? even the output of dmesg may help. By the way, I don't think you'll get much help on a raspberry pi help forum for a potato Dec 12, 2022 at 22:29
  • This is a Linux networking problem, rather than a Raspberry Pi one.
    – NomadMaker
    Jan 15, 2023 at 1:01

1 Answer 1

0

When the error occours:

Start with ifconfig listing, then netstat -r or route, reason is that, often those trouble are seen on multi-homed hosts, and routing conflicts.

If You are sure that only one network interface are up running, then this should not be the case, but as told often a reason for this trouble, could be a driver problem as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.