-1

I have a Raspberry Pi 4 with Raspberry Pi OS Lite (64-bit) installed. I switch it on with Ethernet cable connected, and it doesn't appear on the router's hostname list.

I don't have an SD card if that helps. It's only reading an external hard drive (and a USB that I recently imported). I have tried to restart the router and try again. I've also tried to remove the recently added USB and try again.

I started having this issue a little after I connect the USB (which is an empty one). I neither know if that helps.

Connection to the available hostnames with ssh fails, and that's reasonable because neither of those is raspberry pi.

Edit: These are the last lines from syslog:

Dec 11 23:08:44 raspibolt systemd[1]: Stopping Session 4 of user admin.
Dec 11 23:08:44 raspibolt systemd[1]: Removed slice system-modprobe.slice.
Dec 11 23:08:44 raspibolt Tor[634]: Interrupt: exiting cleanly.
Dec 11 23:08:44 raspibolt systemd[1]: Stopped target Multi-User System.
Dec 11 23:08:45 raspibolt systemd[1]: Stopped target Login Prompts.
Dec 11 23:08:45 raspibolt ModemManager[585]: <info>  caught signal, shutting down...

Second edit: I plugged an HDMI to see what's going on. This is what it returned: https://i.ibb.co/rZNHsV5/image.png

4
  • It's only reading an external hard drive - it probably isn't ... what type of external hard drive is it? what USB to SATA device are you using? Some don't work well at all (Sabrent is hot garbage for one) Also, pi4 won't necessarily boot from USB at all, depending on the version of firmware in the EEPROM Dec 13, 2022 at 10:06
  • @JaromandaX, it's a 1TB HDD Seagate. It had been reading it until that happened. Now I don't know if it does read it. I had configured to boot from USB (and I had inserted a SD card, but just for once at start)
    – Angelo M.
    Dec 13, 2022 at 10:34
  • Oh, I didn't realise that it ever worked ever Dec 13, 2022 at 10:43
  • There you have it, as the picture say, Unable to read partition as FAT. Your harddrive isnt bootable.
    – MatsK
    Dec 13, 2022 at 16:29

1 Answer 1

0

These are the last lines from syslog...

They're dated from 2 days ago; although this could be because it could not connect to a NTP server and hence could not get the correct time, this is also part of the shutdown sequence, meaning it was cleanly shutdown, which is not possible if running headless and offline (ie., inaccessible) unless you have some kind of shutdown implementing power switch.

Based on your screenshot (BTW: Seriously? Is it so hard to actually take a clear, front view pic?), it is not booting because it cannot find a vfat partition to load the second stage bootloader, firmware, and OS kernel from. This could be because data on the drive is corrupted, you should check it in another computer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.