2

How configure the Raspberry 3 B+ to connect only to the 5GHZ network and not to the 2.4GHZ network?

Its revision 1.3

The output from sudo iwlist wlan0 scan | grep Frequency

Frequency:2.437 GHz (Channel 6)
Frequency:2.437 GHz (Channel 6)
Frequency:2.437 GHz (Channel 6)
Frequency:5.32 GHz (Channel 64)
Frequency:5.32 GHz (Channel 64)
Frequency:5.32 GHz (Channel 64)
Frequency:5.24 GHz (Channel 48)
Frequency:5.24 GHz (Channel 48)
Frequency:5.24 GHz (Channel 48)
Frequency:5.24 GHz (Channel 48)
Frequency:5.24 GHz (Channel 48)
7
  • Does this answer your question? Disable 5Ghz Wifi-band on Raspberry Pi 3B+
    – MatsK
    Commented Dec 16, 2022 at 17:13
  • unfortunately not because I need this service done the other way around. I tried it but unfortunately it didn't work
    – User
    Commented Dec 19, 2022 at 12:42
  • You miss the point! In that URL the explain how you specify 2.4GHz frequency's, do the same but change the 2,4 GHz frequencies to 5GHz!
    – MatsK
    Commented Dec 20, 2022 at 5:36
  • Witch revision of Raspberry Pi 3+ do you have ? I suspect it is rev. 1.3, but please verify! And what result does sudo iwlist wlan0 scan | grep Frequency produce?
    – MatsK
    Commented Dec 20, 2022 at 12:02
  • That's right, I own the revision 1.3. The result is like this when typing this command: Frequency:2.437 GHz (Channel 6) Frequency:2.437 GHz (Channel 6) Frequency:2.437 GHz (Channel 6) Frequency:5.32 GHz (Channel 64) Frequency:5.32 GHz (Channel 64) Frequency:5.32 GHz (Channel 64) Frequency:5.24 GHz (Channel 48) Frequency:5.24 GHz (Channel 48) Frequency:5.24 GHz (Channel 48) Frequency:5.24 GHz (Channel 48) Frequency:5.24 GHz (Channel 48)
    – User
    Commented Dec 21, 2022 at 7:12

1 Answer 1

0

It is easy to select the frequencies you want to use. wpa_supplicant has an option freq_list. Just add this line to your /etc/wpa_supplicant/wpa_supplicant.conf:

freq_list=5170 5180 5190 5200 5210 5220 5230 5240 5260 5280 5300 5320 5500 5520 5540 5560 5580 5600 5620 5640 5660 5680 5700

Then your WiFi will only connect to those frequencies.

Ref.: https://raspberrypi.stackexchange.com/a/107861/79866

3
  • I tried this solution but unfortunately it doesn't work
    – User
    Commented Dec 20, 2022 at 7:36
  • Did any SSID show up on both 2,4 and 5GHz?
    – MatsK
    Commented Dec 22, 2022 at 4:53
  • Yes and not just once :)
    – User
    Commented Dec 22, 2022 at 9:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.