1

I'm using a RasPi 4B with a HiFiBerry Amp2 "on top" and a Waveshare 7" (C) touch LCD Rev 2.1.

The setup is intended to become my "web radio" using Volumio or Kodi.

I'm having the problem on each of the following:

  • LibreELEC,
  • OSMC and
  • the latest Raspian

The problem is that the touch function of the LCD doesn't work after boot. Resetting the USB bus via

echo "0" | sudo tee /sys/bus/usb/devices/1-1.4\:1.0/authorized
echo "1" | sudo tee /sys/bus/usb/devices/1-1.4\:1.0/authorized

doesn't help.

Only after un- and replugging the USB cable does the touch screen come alive.

I'm including the (Raspian) output of

dmesg | grep -i usb
below, it shows the effect of the echo "0" | sudo tee ... commands at 31.711333 (inserted manually) and the un-/replugging action starting at 95.183393.

The touch screen doesn't work at the 31.711333 point, but works just after 98.256108.

How do I get the touch screen to work at boot? Or how can I reset it via software shortly after boot?

[    0.164701] usbcore: registered new interface driver usbfs
[    0.164754] usbcore: registered new interface driver hub
[    0.164837] usbcore: registered new device driver usb
[    0.165184] usb_phy_generic phy: supply vcc not found, using dummy regulator
[    0.165379] usb_phy_generic phy: dummy supplies not allowed for exclusive requests
[    1.348498] usbcore: registered new interface driver r8152
[    1.348561] usbcore: registered new interface driver lan78xx
[    1.348636] usbcore: registered new interface driver smsc95xx
[    1.350398] xhci_hcd 0000:01:00.0: new USB bus registered, assigned bus number 1
[    1.351893] xhci_hcd 0000:01:00.0: new USB bus registered, assigned bus number 2
[    1.351916] xhci_hcd 0000:01:00.0: Host supports USB 3.0 SuperSpeed
[    1.352278] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002, bcdDevice= 5.15
[    1.352298] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.352312] usb usb1: Product: xHCI Host Controller
[    1.352325] usb usb1: Manufacturer: Linux 5.15.76-v8+ xhci-hcd
[    1.352338] usb usb1: SerialNumber: 0000:01:00.0
[    1.353080] hub 1-0:1.0: USB hub found
[    1.354195] usb usb2: New USB device found, idVendor=1d6b, idProduct=0003, bcdDevice= 5.15
[    1.354216] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.354231] usb usb2: Product: xHCI Host Controller
[    1.354244] usb usb2: Manufacturer: Linux 5.15.76-v8+ xhci-hcd
[    1.354257] usb usb2: SerialNumber: 0000:01:00.0
[    1.354912] hub 2-0:1.0: USB hub found
[    1.357568] usbcore: registered new interface driver uas
[    1.357672] usbcore: registered new interface driver usb-storage
[    1.368003] usbcore: registered new interface driver usbhid
[    1.368016] usbhid: USB HID core driver
[    1.615275] usb 1-1: new high-speed USB device number 2 using xhci_hcd
[    1.765952] usb 1-1: New USB device found, idVendor=2109, idProduct=3431, bcdDevice= 4.21
[    1.766001] usb 1-1: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[    1.766027] usb 1-1: Product: USB2.0 Hub
[    1.768228] hub 1-1:1.0: USB hub found
[    2.063325] usb 1-1.4: new full-speed USB device number 3 using xhci_hcd
[    2.170474] usb 1-1.4: New USB device found, idVendor=0eef, idProduct=0005, bcdDevice= 2.00
[    2.170513] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    2.170528] usb 1-1.4: Product: By ZH851
[    2.170542] usb 1-1.4: Manufacturer: BYZHYYZHY
[    2.170555] usb 1-1.4: SerialNumber: `\x12P357v\x112033
[    2.184609] input: BYZHYYZHY By ZH851 Mouse as /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.4/1-1.4:1.0/0003:0EEF:0005.0001/input/input0
[    2.185112] input: BYZHYYZHY By ZH851 Touchscreen as /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.4/1-1.4:1.0/0003:0EEF:0005.0001/input/input1
[    2.185836] hid-generic 0003:0EEF:0005.0001: input,hiddev96,hidraw0: USB HID v1.10 Mouse     [BYZHYYZHY By ZH851] on usb-0000:01:00.0-1.4/input0
[    5.528200] usbcore: registered new interface driver brcmfmac
[    6.482589] input: BYZHYYZHY By ZH851 as /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.4/1-1.4:1.0/0003:0EEF:0005.0001/input/input3
[    6.655637] hid-multitouch 0003:0EEF:0005.0001: input,hiddev96,hidraw0: USB HID v1.10 Mouse     [BYZHYYZHY By ZH851] on usb-0000:01:00.0-1.4/input0
[   31.711333] cam-dummy-reg: disabling
[   95.183393] usb 1-1.4: USB disconnect, device number 3
[   95.412401] usb 1-1.4: new full-speed USB device number 4 using xhci_hcd
[   95.700659] usb 1-1.4: device descriptor read/64, error -32
[   95.915494] usb 1-1.4: New USB device found, idVendor=0eef, idProduct=0005, bcdDevice= 2.00
[   95.915523] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[   95.915540] usb 1-1.4: Product: By ZH851
[   95.915553] usb 1-1.4: Manufacturer: BYZHYYZHY
[   95.915566] usb 1-1.4: SerialNumber: `\x12P357v\x112033
[   95.932277] input: BYZHYYZHY By ZH851 as /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.4/1-1.4:1.0/0003:0EEF:0005.0002/input/input5
[   95.936424] hid-multitouch 0003:0EEF:0005.0002: input,hiddev96,hidraw0: USB HID v1.10 Mouse     [BYZHYYZHY By ZH851] on usb-0000:01:00.0-1.4/input0
[   96.207367] usb 1-1.4: USB disconnect, device number 4
[   98.136375] usb 1-1.4: new full-speed USB device number 5 using xhci_hcd
[   98.243448] usb 1-1.4: New USB device found, idVendor=0eef, idProduct=0005, bcdDevice= 2.00
[   98.243463] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[   98.243470] usb 1-1.4: Product: By ZH851
[   98.243475] usb 1-1.4: Manufacturer: BYZHYYZHY
[   98.243481] usb 1-1.4: SerialNumber: `\x12P357v\x112033
[   98.255715] input: BYZHYYZHY By ZH851 as /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.4/1-1.4:1.0/0003:0EEF:0005.0003/input/input7
[   98.256108] hid-multitouch 0003:0EEF:0005.0003: input,hiddev96,hidraw0: USB HID v1.10 Mouse     [BYZHYYZHY By ZH851] on usb-0000:01:00.0-1.4/input0

Update 1: I'm getting the same behaviour on an Odroid-N2+.

Update 2: Same problem when connecting to my linux laptop (via docking station)

3
  • 1
    have you tried without the HiFiBerry? Commented Dec 18, 2022 at 23:03
  • @JaromandaX no, but with an Odroid-N2+. Same problem. :(
    – doppelfish
    Commented Dec 27, 2022 at 22:59
  • not sure how that is relevant Commented Dec 27, 2022 at 23:03

1 Answer 1

0

Update 3: Bought a new LCD of the same kind, which now works fine. Most likely, the old LCD was simply broken, as its touchscreen should have worked up front.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.