Having a few problems with the standard camera board.

  1. Images are heavily green-tinted: sample
  2. Anytime I try to use the raspistill -fp option, it takes about 20 seconds after the snapshot is taken for the desktop to respond to my input again.

I also just executed rpi-update to update the firmware, but no change (well the second problem seems to have improve a little). Command executed for the above snapshot:

raspistill -fp -q 100 -o rcapture.jpg

For the first problem, the camera seems kind of finicky. I often get travelling lines on the preview and it's heavily green tinted as you can see from the picture. I managed a properly coloured picture once or twice, but it doesn't seem reproducible now.

For the second problem, the first time and second time raspistill -fp is executed, it returns desktop control immediately. All subsequent times my mouse and keyboard don't respond for a good 10-15 secs, then I finally get control back. This also happens in preview only mode, ie. when not saving a picture. All I need to execute is "raspistill -fp" a few times to see this behaviour. When executing "raspistill -fp -k", it also doesn't quit when I type "x" and hit the enter key like it's supposed to (waited a good 30 seconds).

I've also tried two different regulated power supplies, same behaviour with each.

Anyone else having these problems or can suggest any solutions?

5 Answers 5


I noticed the same strong green tint also whenever I use raspistill -ex night, where I was trying to set up for astrophotograhy shots of the starry night sky. night mode very geren

My solution was to stop using night mode and set up the shutter speed manually. raspistill -ss 500000 half second shutter speed

Note: Shots without night mode were colored properly, so no the cable, though I also tried re-seating the heck out of the ribbon cable with no change to night mode


first, the flag -k doesn't seem to be documented anywhere. Second, do you have any other processes (especially ones that use the camera, e.g. Motion) that are running at the same time as when you run raspistill? I suppose CPU could be an issue with problem 2. I had trouble with the camera when motion was still using it, this could be problem 1.

  • The -k flag is documented in the raspistill usage info, ie. "raspistill --help". All I have running is VNC, which wasn't being used, and the desktop I was using to work on the device. Pretty sure the problems were happening before I ran VNC anyway. I haven't set up anything else to work with sensors or anything, I'm just getting started on the camera, so unless something on a stock raspbian interferes by default...
    – naasking
    Mar 3, 2014 at 2:52

As far as the green tint is concerned, I was having a similar issue. For me the problem was that the ribbon was not seated properly in the connecter. After adjusting the ribbon connection, the output from the camera looked correct.


I had the same issue when turned white-balance off (--awb off). Using '--awb sun' helped.

However the truth is that the cable does not sit firmly so this might be an issue also.


raspistill Camera App v1.3.8 has support for the -st command, and it fixed the color shading problem I was having on all of my weather cameras. http://www.IWVWeather.com

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.