1

I've just setup my Raspberry Pi 4 (Raspian OS version 10\Buster) with Jellyfin. All my media (for Jellyfin) is on a Win 2016 Server (running AD\DNS\DHCP) in different folders.

I setup mapping to the Movies folder on the Win Server (which works - and ive got Jellyfin to index the content) via modifying /etc/fstab with this line; //192.168.0.10/Movies /home/pi/Server/Movies cifs username=username,password=password 0 0 & giving Jellyfin the movies folder location as /home/pi/Server/Movies. Obviously the new folders were created in /hom/pi/... before hand.

But, my TV shows are in a folder on the Win Server with a space in the name - so its at //192.168.0.10/TV Shows I tested being able to mount this just via a simple (with a single quotation mark surrounding the address): sudo mount -t cifs -o username=username,password=password '//192.168.0.10/TV Shows' Server/TV-Shows which worked fine.

but it appears i can't use the single quotation marks in fstab as it wont map to it with: '//192.168.0.10/TV Shows' /home/pi/Server/TV-Shows cifs username=username,password=password 0 0

Any suggestions? Or am i missing something else?

Edit note - if i run sudo mount -av i get a parse error on the line for TV Shows folder whether i use: '//192.168.0.10/TV Shows' /home/pi/Server/TV-Shows cifs username=username,password=password 0 0 or if i use //192.168.0.10/TV Shows /home/pi/Server/TV-Shows cifs username=username,password=password 0 0 I also tried to use an escape with this: //192.168.0.10/TV\ Shows /home/pi/Server/TV-Shows cifs username=username,password=password 0 0 but still got the parse error.

1 Answer 1

0

i found the answer after more googling around debian... fstab has it's own syntax - you have to specify its code-point as a zero padded 3-digit octal number preceded by a backslash. thanks to this post: https://superuser.com/questions/527495/how-to-mount-partition-with-spaces-in-path

so where i was trying to do: //192.168.0.10/TV Shows /home/pi/Server/TV-Shows cifs username=username,password=password 0 0, well it needs to be expressed as: //192.168.0.10/TV\040Shows /home/pi/Server/TV-Shows cifs username=username,password=password 0 0.

Thus \040 defines a space.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.