1

Overnight my pi-hole disappeared, it had been running fine for months, then one morning... gone, I've been unable to ping the Raspberry Pi Zero or ssh to it. It has a fixed IP, assigned by the router for the onboard WIFI - but the router doesn't show it when I power up the pi.

I have tried disconnecting and reconnecting my zero, removing the SD and checking the SD in my PC, initially, Win11 said there was an issue, but then loaded the contents of the boot volume fine. Next, I tried putting an ssh file on the root and a wpa_supplicant.conf (as I did when initially setting it up) thinking that might let me connect and figure out what's going on.

As far as I can tell the pi boots, the green light flashes for a few minutes then settles down and is stable, but I can't access it.

It was working fine, so I'm assuming something has failed, possibly the onboard WIFI. Is there any way of figuring that out?

I guess I'd need a micro USB to LAN cable and see if that allows a connection, but if that fails, what else can I do, short of replacing the entire pi Zero (assuming I could even locate one, there's a shortage at the time of writing). If I had to do that could I just plug in the SD card and have my pi-hole again?

3
  • The most likely problem is a corrupt OS. Restore from your backup (preferably to a new SD Card).
    – Milliways
    Jan 6, 2023 at 21:38
  • Does your wifi access point show connected devices? Can you see a list of devices your DHCP server has issues IP addresses to? Note, in 99% of cases your wifi access point and DHCP server are probably the same thing, i.e your router Jan 7, 2023 at 0:30
  • My router is set to assign a fixed IP (MAC address bound), but isn't showing it as connected. Jan 9, 2023 at 9:02

1 Answer 1

0

In the end I used the Pi Imager to start again cleanly. Initially I tried to create a new image on a separate SD card with NOOBS but although I could ping the pi, I couldn't SSH to it, so after an hour of trying things there I'd had enough and wiped it to start again. Thankfully that worked, so I assume there was some corruption in something OS or one of the configs.

Sadly I didn't have a backup... so have learned my lesson there!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.