0

I have currently installed the latest raspbian as of posting this question.

I have an i2c device with address 0x03 which works when running my program I successfully communicate with it, but when I run i2cdetect I only see devices starting from address 0x08.

$ i2cdetect -y 1
     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00:                         -- -- -- -- -- -- -- -- 
10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
60: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
70: -- -- -- -- -- -- -- --     

Why is that?

0

1 Answer 1

3

Try i2cdetect -a -y 1

default range is from 0x08 to 0x77

NOTE man i2cdetect will show this (and other options)

3
  • But it used to start at 3 just before I had to reinstall. My old card was some 3 years old so I'm guessing that's an update..
    – php_nub_qq
    Jan 12 at 0:45
  • AFAIK this has been so for years. Some versions use default: from 0x03 to 0x77 but this is Debian Bullseye version
    – Milliways
    Jan 12 at 0:57
  • My old card had raspbian based on buster, and it showed 0x03-0x077, just for reference. What is the reason for the first few addresses to be hidden?
    – php_nub_qq
    Jan 12 at 14:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.