My Pi is 2B Rev1.1

  • I connected HC-08 Bluetooth module on pin8,10.

  • I use Raspberry Pi OS.

  • In /boot/configuration.txt

  • In /boot/cmdline.txt

    console=tty1 root=PATUUID=e77fdc5c-02 rootfstype=ext4 fsck.repair=yes root wait quiet splash Plymouth.ignore-serial-serialconsoles
  • I upgraded the Pi with the command sudo apt update &&sudo apt upgrade

  • I installed bluez with the command sudo apt install bluetooth pi-bluetooth bluez blueman

  • I checked bluetooth status with the command sudo systemctl status bluetooth.service. It shows Active:Inactive(dead).

  • Then I try to use sudo modprobe btusb to get the service up. It shows Active:active(running)

  • I use command bluetoothctl. There is no device found.

  • After further research. I found the following command sudo systemctl status hciuart.service. It shows Active:active(dead).

  • And raspberrypi systemd[1]:condition check resulted in configure Bluetooth Modems connected by UART being skipped

  • After further research, I tried to use the command sudo systemctl hciattach /dev/serial0 bcm43xx 115200. It shows bcm43xx_init Initialization timeout

  • I tried different parameters and still failed to get this done successfully.

So far I am focusing on the error message from hciuart.service. I am trying to figure out what caused the skip.

I am new to the kernel thing. Any help is appreciated.

  • "btusb" would enable a bluetooth USB device, no? "pins 8 and 10" are not a USB device - can you specify exactly what you connected to each pin - I suspect you connected RX to RX and TX to TX - a common rookie mistake Jan 16 at 3:05
  • An HC-08 module will not be recognised by the RPi as a Bluetooth device and doesn't use the Bluetooth software stack used by the on-board Bluetooth on later RPi models. The HC-0* Bluetooth UART Communication Modules work as bridges between the serial communication on the pins of the RPi to Bluetooth over the air. You need a serial library to read/write to the HC-08 device. For example PySerial in Python.
    – ukBaz
    Jan 16 at 6:51
  • @Jaromanda X I was confused about the command to bring bluetooth up too. But btusb worked. Pin8(GPIO14,UART0_TXD)<->RXD on HC-08 module,Pin10(GPIO15,UART0_RXD)<-> TXD on HC-08 module.
    – Daniel
    Jan 17 at 4:18
  • @ukBaz I do not know this. This sounds make sense to me. That maybe the reason it is skipped.I will study Pyserial first. I have another question if this is true, if i use my smart phone to pair with HC-08 module it should work and can pair successfully,right?
    – Daniel
    Jan 17 at 4:19
  • 1
    @ukBaz - Please use the answer section for answers, and not the comment section. Jan 17 at 9:42


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.