-1

So I'm trying to connect my Raspberry Pi Pico to Thonny but I doesn't let me select com4 or anything else except "try to detect port automatically" and when I put it, it does not let me run my script, I checked for it in device manager but it was not there.

1
  • 1
    Abandoned post by Unregistered user.
    – Milliways
    Jul 2, 2023 at 9:39

2 Answers 2

0

Check your usb cable. Some cables are power only, and some are data and power. The port may recgonize it, but make not be able to do anything as it cannot transfer any data. I suggest using a different cable. I ran into the same exact issue, but all I needed was to change the cable.

Hope this helps!

0

If it's not in device manager then you'll never connect and you can't run a script unless your Pico is connected.

Open Windows Device Manager and look at ports while you connect and disconnect.

Mine shows up as com 9 so I had to select port 9 under tools > options > interpreter > port in Thonny.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.