0

I'm wondering if anyone else has run into issues like this and if they found the cause of it.

So I have a 'process' - any new machines get set up on my workbench (which has an old 22" 1920x1080) Dell screen. So I set up my Raspberry Pi 4 on the Workbench (as it's going in the bedroom as a Media Center), install OpenElec on it... and some addons into Kodi, and make sure it's all working (Here's how it looks on the Workbench 22" screen) enter image description here

I then go and plug it into the TV in the bedroom, which is an old Hisense 42" dumb screen (pre 'smart' TVs) and it looks like this... enter image description here To confirm there's nothing wrong with the TV, I then plug in the old SFF Dell PC running Windows 10 & Kodi which has been connectedbeforeo this Raspberry Pi... and yep, the screen is fine & looks like this. enter image description here

For some technical notes: The 22" Dell monitor on the workbench just has a VGA cable connected, then I had a VGA to HDMI Adapter plugged into that & an HDMI to Micro HDMI Adapter plugged into that (to effectively convert VGA to micro HDMI).

The 42" TV was just using HDMI when plugged into the SFF Dell PC running Win10. When connecting the Raspberry Pi to the TV, all I was using was the Micro HDMI adapter (but otherwise still using the same HDMI cable which was used with the Dell SFF).

And just to make it interesting, I then test out the VGA cable on the 42" TV - so it's doing the same as on the Workbench which was VGA to micro HDMI... and its display is okay, but can only do 1024x768 resolution (on the Dell SFF it was displaying at 1920x1080) enter image description here

And to make sure it wasn't OpenElec somehow, I then installed Raspian OS instead - tested that on the TV & it has the same display issue. I also tested using different Kodi skins being used.

Is the OS somehow 'locked' to only support the video communication method used during installation - it was installed with VGA, so it's bound to using VGA. Could there be an issue with HDMI on the TV, and somehow receiving HDMI from the Raspberry Pi it can't handle (when it can handle HDMI from a Dell SFF with Win10)?

2 Answers 2

2

I had the same issue before. The issue is the monitor. It is too old to support the Raspberry Pi 4's input. As far as I know, I don't think you can change the settings to fix this. Try using newer monitors. They should work with the Raspberry Pi.

It is possible that HDMI supports better graphics, and since the Raspberry Pi uses HDMI, VGA can't handle the new graphics and may display them wrongly. Adapters always have a chance of not working because it is trying to convert something, and there are chances that they won't be able to convert it right.

In your situation, the adapter tried to make new graphics go to an old monitor that doesn't know how to display the new graphics. It will have to try to make it so that the monitor can understand the output from the Raspberry Pi.

Reference: This answer to Arch Overscan Screen Slanted

3
  • 4
    This could be a very useful/popular answer if you could add some specifics, and an explanation of the issue.
    – Seamus
    Commented Jan 26, 2023 at 19:42
  • Ok, I tried to make it as detailed as I can. Hope it is understandable!
    – LilData777
    Commented Jan 26, 2023 at 19:55
  • Thanks for the suggestion!
    – LilData777
    Commented Jan 26, 2023 at 22:48
2

Just posting this comment if it helps anyone else, after doing more research;

So unlike a normal PC, the Pi doesn't have a BIOS/UEFI. But the Pi does have a config.txt file that holds some of this info (the config file is located at \boot\config.txt which from my understanding is also the boot sector for the memory card).

Installing on the Pi when connected to a computer monitor via VGA which I had been doing (with HDMI Adapter) I suspect would give the config.txt file an HDMI_group of '1' (for Consumer electronics - computer monitor) and HDMI_mode of (maybe) '1' also (as its using VGA adapter). Or well that's referring to this doc from I believe was the Pi 1 https://onlinelibrary.wiley.com/doi/pdf/10.1002/9781119415572.app3

And further looking I found this on Adafruit https://learn.adafruit.com/using-weird-displays-with-raspberry-pi/everything-else that is to say, there's a myriad of configs that can be done for the Pi 4 on HDMI & I suspect this TV (when using HDMI) falls into the category of 'weird' displays. And as this TV is very old (i believe it was purchased around 2009 - as I just got it from someone else) I have to wonder if the TV only conforms to maybe HDMI 1.2 version (speculating here) as it was a cheap manufacturer.

Anyway, I've decided I will buy a new TV rather than continue trying to config the Pi for the TV - as a local store has a 40" LED model for $300 (AUS dollars - I suspect prices would be very diff in the US or Canada). The newer screen should use a bit less power than this dinosaur TV & hopefully it will be easier with the Pi.. so by spending money I'll save money in the long run hopefully (on the power bill & my time).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.