2

My mouse stopped working a few days ago and is unable to work since then. I tried but fail to pair it again through either Terminal or Settings > Bluetooth. The Bluetooth right now is able to discover other blue devices but is just unable to pair any.

raspberry:~$ bluetoothctl
Agent registered
[CHG] Device 6A:74:F0:20:DA:22 RSSI: -73
[CHG] Device 6A:74:F0:20:DA:22 ManufacturerData Key: 0x004c
[CHG] Device 6A:74:F0:20:DA:22 ManufacturerData Value:
  07 19 01 0f 20 02 f8 8f 01 00 06 7e fc 18 87 93  .... ......~....
  92 9e 4c e1 df 90 0b 56 4f cc 5e                 ..L....VO.^     
[DEL] Device 75:63:D5:1D:9A:CB 75-63-D5-1D-9A-CB
[CHG] Device 00:42:79:C3:CB:6D RSSI: -68
[CHG] Device 62:D6:F1:DD:28:60 RSSI: -74
[CHG] Device 62:D6:F1:DD:28:60 ManufacturerData Key: 0x004c
[CHG] Device 62:D6:F1:DD:28:60 ManufacturerData Value:
  0c 0e 00 3a 69 3c 20 8c d3 94 fb 1c b5 9e 7a e9  ...:i< .......z.
  10 06 3d 1d 6b 2e af 98                          ..=.k...        
[CHG] Device 00:42:79:C3:CB:6D RSSI: -68
[bluetooth]# show
Controller DC:A6:32:D9:2A:26 (public)
    Name: raspberry
    Alias: raspberry
    Class: 0x007c0000
    Powered: yes
    Discoverable: yes
    DiscoverableTimeout: 0x000000b4
    Pairable: yes
    UUID: Message Notification Se.. (00001133-0000-1000-8000-00805f9b34fb)
    UUID: A/V Remote Control        (0000110e-0000-1000-8000-00805f9b34fb)
    UUID: OBEX Object Push          (00001105-0000-1000-8000-00805f9b34fb)
    UUID: Message Access Server     (00001132-0000-1000-8000-00805f9b34fb)
    UUID: PnP Information           (00001200-0000-1000-8000-00805f9b34fb)
    UUID: IrMC Sync                 (00001104-0000-1000-8000-00805f9b34fb)
    UUID: Vendor specific           (00005005-0000-1000-8000-0002ee000001)
    UUID: Headset                   (00001108-0000-1000-8000-00805f9b34fb)
    UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
    UUID: Generic Attribute Profile (00001801-0000-1000-8000-00805f9b34fb)
    UUID: Phonebook Access Server   (0000112f-0000-1000-8000-00805f9b34fb)
    UUID: Device Information        (0000180a-0000-1000-8000-00805f9b34fb)
    UUID: Audio Sink                (0000110b-0000-1000-8000-00805f9b34fb)
    UUID: Generic Access Profile    (00001800-0000-1000-8000-00805f9b34fb)
    UUID: Handsfree Audio Gateway   (0000111f-0000-1000-8000-00805f9b34fb)
    UUID: Audio Source              (0000110a-0000-1000-8000-00805f9b34fb)
    UUID: OBEX File Transfer        (00001106-0000-1000-8000-00805f9b34fb)
    Modalias: usb:v1D6Bp0246d0541
    Discovering: yes
    Roles: central
    Roles: peripheral
Advertising Features:
    ActiveInstances: 0x00 (0)
    SupportedInstances: 0x05 (5)
    SupportedIncludes: tx-power
    SupportedIncludes: appearance
    SupportedIncludes: local-name
[bluetooth]# agent on
Agent is already registered
[bluetooth]# default-agent
Default agent request successful
[bluetooth]# pairable on
Changing pairable on succeeded
[bluetooth]# scan on
Discovery started
[NEW] Device ED:8E:0E:C0:BB:61 RAPOO BleMouse
[bluetooth]# pair ED:8E:0E:C0:BB:61
Attempting to pair with ED:8E:0E:C0:BB:61
[CHG] Device ED:8E:0E:C0:BB:61 Connected: yes
[NEW] Primary Service (Handle 0x0000)
    /org/bluez/hci0/dev_ED_8E_0E_C0_BB_61/service0008
    00001801-0000-1000-8000-00805f9b34fb
    Generic Attribute Profile
[NEW] Characteristic (Handle 0x0000)
    /org/bluez/hci0/dev_ED_8E_0E_C0_BB_61/service0008/char0009
    00002a05-0000-1000-8000-00805f9b34fb
    Service Changed
[NEW] Descriptor (Handle 0x0000)
    /org/bluez/hci0/dev_ED_8E_0E_C0_BB_61/service0008/char0009/desc000b
    00002902-0000-1000-8000-00805f9b34fb
    Client Characteristic Configuration
[NEW] Primary Service (Handle 0x0000)
    /org/bluez/hci0/dev_ED_8E_0E_C0_BB_61/service000c
    0000180a-0000-1000-8000-00805f9b34fb
    Device Information
[NEW] Characteristic (Handle 0x0000)
    /org/bluez/hci0/dev_ED_8E_0E_C0_BB_61/service000c/char000d
    00002a29-0000-1000-8000-00805f9b34fb
    Manufacturer Name String
[NEW] Characteristic (Handle 0x0000)
    /org/bluez/hci0/dev_ED_8E_0E_C0_BB_61/service000c/char000f
    00002a50-0000-1000-8000-00805f9b34fb
    PnP ID
[NEW] Primary Service (Handle 0x0000)
    /org/bluez/hci0/dev_ED_8E_0E_C0_BB_61/service0011
    0000180f-0000-1000-8000-00805f9b34fb
    Battery Service
[NEW] Characteristic (Handle 0x0000)
    /org/bluez/hci0/dev_ED_8E_0E_C0_BB_61/service0011/char0012
    00002a19-0000-1000-8000-00805f9b34fb
    Battery Level
[NEW] Descriptor (Handle 0x0000)
    /org/bluez/hci0/dev_ED_8E_0E_C0_BB_61/service0011/char0012/desc0014
    00002902-0000-1000-8000-00805f9b34fb
    Client Characteristic Configuration
[CHG] Device ED:8E:0E:C0:BB:61 UUIDs: 00001800-0000-1000-8000-00805f9b34fb
[CHG] Device ED:8E:0E:C0:BB:61 UUIDs: 00001801-0000-1000-8000-00805f9b34fb
[CHG] Device ED:8E:0E:C0:BB:61 UUIDs: 0000180a-0000-1000-8000-00805f9b34fb
[CHG] Device ED:8E:0E:C0:BB:61 UUIDs: 0000180f-0000-1000-8000-00805f9b34fb
[CHG] Device ED:8E:0E:C0:BB:61 UUIDs: 00001812-0000-1000-8000-00805f9b34fb
[CHG] Device ED:8E:0E:C0:BB:61 ServicesResolved: yes
[CHG] Device ED:8E:0E:C0:BB:61 Modalias: usb:v1235pAA22d0001
[CHG] Device ED:8E:0E:C0:BB:61 ServicesResolved: no
[CHG] Device ED:8E:0E:C0:BB:61 Connected: no
Failed to pair: org.bluez.Error.AuthenticationCanceled

Would anyone please help? I can see the JBL, and other bluetooth devices, just can't pair.

I tried to pair and connect with Blueman. Same result, my mouse can be found, but can't be paired and connected. The error message is:

Connection Failed: org.freedesktop.DBus.Error.UnknownObject Method "Connect" with signature "" on interface "org.bluez.Device1" doesn't exist
3
  • 1
    The JGL must be turned on first, then at least 2-3 minutes before RPi powered up. Then start connect 0 Feb 3, 2023 at 1:52
  • would you please tell me what actually i have to do? How to turn on JGL?
    – yts61
    Feb 3, 2023 at 8:11
  • Sorry. It was misspelled error. JBL not JGL. Is Wait a minute is JBL is Bluetooth mouse? If yes ........ connect to port USB 2 not NOT USB 3. You don't need to paired. It is plug and go. I had it on my 7 ports HUB. Otherwise check your battery. Feb 3, 2023 at 14:48

1 Answer 1

0
  1. please check rfkill

rfkill list

  1. If any of it is blocked, be it soft or hard, just unblock it.

rfkill unblock all

or rfkill unblock <device name>

I would just unblock all simply.

  1. Finally bluetoothctl power on.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.