So I have an old Rpi2 B, and I was getting an undervoltage error trying to run OctoPrint on an old bundled PSU.

I swapped for a 5V/4A PSU with the same error, I only have the power supply and an Ethernet cable connected. Could my Pi be broken in some way?

I took it a step further and ran 5.15V on the GPIO pins from a decent lab PSU. (I know it's risky, but it's a last resort.) This drew around 400 mA and still had the same error. I then tested the voltage out of the USB sockets and found around 4.8 v.

My theory was that plugging in my 3D printer would pull enough current to under-volt the PI; however, even without the printer connected, the issue still occurs, so even that theory is out the window.


1 Answer 1


The latest official documentation on power requirements for all models of RPi shows:

Product PSU current rating Max USB current draw Typ bare-board current used
RPi 2 Model B 1.8A 1.2A 350mA

If your measurements are accurate, and you're not overclocking, your RPi is drawing a bit more current than specified, but not by a large amount. The other thing that can cause voltage drops is long power leads, or small wire gauge. Adjust this if possible with the shortest cable & largest AWG leads you can find.

You should also check your board revision (it seems there was at least one revision), and review the schematic. Referring to the 2B schematic, there is no voltage regulator, only a fusible link (F3; a.k.a. polyfuse): the 5V0 bus comes straight from the USB input. You should measure 5V0 between TP1 and TP2 & compare it against the reading on your external PS. If you have an oscilloscope, you could also take a look at 5V0 just to make sure it's quiet & stable.

If you make these measurements carefully, you may get useful information to further your troubleshooting. In other words, consider the elements in series with the supply: connectors, wire, fusible link, and note the voltage drops at each point.

You can also monitor GPIO35 in software on the RPi 2B for state transitions (high to low), and/or use the vcgencmd command to gain some insights on how your system is performing. There are a couple of good answers that provide the "how-to" details to accomplish these tests.

The fact that the 2B has no voltage regulator between VIN and 5V0 suggests to me that your problem may be in the wiring or connectors, but there are numerous reports online re. issues with the polyfuse (F3 on the schematic) - for example.

Other than that, I'm not aware of any specific under-voltage issues with the 2B. If you find no issues with the steps described above, my advice would be to:

  1. keep power leads short,
  2. use heaviest AWG you can find, and
  3. drive on

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.