2

My Goal:

I'm trying to setup my raspi to host a nextcloud server, and I've also purchased a domain name; let's say it's www.johndoe.com . My goal is to be able to log in to this cloud from any machine at the url www.johndoe.com/nextcloud.

Edit: Solution: I hadn't set up port-forwarding for http for the domain johndoe.com within my router's config. Having done that now, the cloud hosting is working. Dumb mistake that isn't related to the raspi, Sorry everyone.

My approach, and the problem:

The instructions I'm following here are great (alternative suggestions also welcome), however the problems start when I get to the section "Nextcloud Initial Setup", as I am not able to connect from other devices. To work around this and complete the initial setup, I worked from the raspi itself at the url localhost/nextcloud. That works fine. I've also got the raspi's IP address using $hostname -I, (let's say it's 123.456). However I cannot connect via the domain.

To narrow things down:

  • When I type in 123.456 into the browser of my laptop, I get the Apache2 Debian Default Page, which establishes that my raspi is connected to the network and able to host.

  • When I type in http://123.456/nextcloud/ on my laptop, I'm able to connect to the cloud on the raspi (provided I add 123.456 to the "trusted_domains" setting in config/config.php). This establishes that http connection from my laptop to the nextcloud instance on the raspi is also working.

  • When I open a terminal on my laptop and type $ssh [user]@johndoe.com I'm able to connect headless to the raspi. This establishes that the domain name is properly forwarding to my raspi.

However, when I type http://www.johndoe.com/nextcloud/ into that same laptop browser, I get "Unable to connect" (even with johndoe.com included in "trusted_domains")

My best guess:

My first doubts were at the point where I had to choose between "Running Under a Directory" and "Running NextCloud on its own domain" (which determines what one should use for the nextcloud.conf file). The choice seems unclear to me, because johndoe.com is the domain for the raspi. Can someone clarify which version of the nextcloud.conf file I want?

Any suggestions or observations would be much appreciated (also please let me know if I'm posting this in the wrong place).

3
  • Please edit your question and add more details. Are you trying to connect to http://johndoe.com/nextcloud from the same computer where you can use ssh [email protected]. Use a network sniffer like Wireshark or tcpdump to see what exactly happens when you try to connect using your browser.
    – Bodo
    Feb 14, 2023 at 17:56
  • Thanks for the suggestion. Yes, the laptop where I ssh into my raspi at johndoe.com is the same machine from which I cannot access the http link.
    – Jabber1
    Feb 15, 2023 at 18:54
  • Sorry, I just realized that I wasn't forwarding all the necessary ports to the raspi. Problem solved.
    – Jabber1
    Feb 15, 2023 at 19:47

1 Answer 1

0

Had to add port-forwarding for http. Everything works now.

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .