3
$ sudo apt upgrade

Reading package lists... Done

Building dependency tree... Done

Reading state information... Done
Calculating upgrade... Done

The following packages were automatically installed and are no longer required:

  libfuse2 raspinfo

Use 'sudo apt autoremove' to remove them.

The following NEW packages will be installed:
  kms++-utils raspi-utils

The following packages will be upgraded:
  base-files bind9-host bind9-libs curl dbus dbus-user-session dbus-x11
  distro-info-data git git-man isc-dhcp-client isc-dhcp-common libbluray2
  libcurl3-gnutls libcurl4 libdbus-1-3 libde265-0 libexpat1 libexpat1-dev
  libgnutls30 libgssapi-krb5-2 libjavascriptcoregtk-4.0-18 libk5crypto3
  libkrb5-3 libkrb5support0 libksba8 libmaven-shared-utils-java libnftables1
  libntfs-3g883 libopenexr25 libpq5 libtasn1-6 libtiff5 libuv1 libvncclient1
  libwebkit2gtk-4.0-37 libxml2 nano nftables ntfs-3g openjdk-11-jdk-headless
  openjdk-11-jre-headless raspinfo sudo tzdata
45 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 243 MB/244 MB of archives.

After this operation, 8,718 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y

Err:1 http://raspbian.raspberrypi.org/raspbian bullseye/main armhf dbus armhf 1.12.24-0+deb11u1
  Connection failed [IP: 103.195.68.3 80]

Err:2 http://raspbian.raspberrypi.org/raspbian bullseye/main armhf libdbus-1-3 armhf 1.12.24-0+deb11u1
  Connection failed [IP: 103.195.68.3 80]

Err:3 http://raspbian.raspberrypi.org/raspbian bullseye/main armhf libexpat1-dev armhf 2.2.10-2+deb11u5
  Connection failed [IP: 103.195.68.3 80]

Err:4 http://raspbian.raspberrypi.org/raspbian bullseye/main armhf libexpat1 armhf 2.2.10-2+deb11u5
  Connection failed [IP: 103.195.68.3 80]

E: Failed to fetch http://raspbian.mirror.net.in/raspbian/raspbian/pool/main/d/dbus/dbus_1.12.24-0+deb11u1_armhf.deb  Connection failed [IP: 103.195.68.3 80]

E: Failed to fetch http://raspbian.mirror.net.in/raspbian/raspbian/pool/main/d/dbus/libdbus-1-3_1.12.24-0+deb11u1_armhf.deb  Connection failed [IP: 103.195.68.3 80]

E: Failed to fetch http://raspbian.mirror.net.in/raspbian/raspbian/pool/main/o/openjdk-11/openjdk-11-jre-headless_11.0.18+10-1~deb11u1_armhf.deb  Connection failed [IP: 103.195.68.3 80]

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
1
  • 4
    Try again, you've had a transient connection error.
    – Dougie
    Commented Feb 17, 2023 at 10:16

3 Answers 3

5

Change the repository server by editing below file using

sudo nano /etc/apt/sources.list

Try another repository from the list given in
https://www.raspbian.org/RaspbianMirrors

change the below line with the new repository :

deb http://raspbian.raspberrypi.org/raspbian/ bullseye main contrib non-free rpi

1
  • I tried it but it takes too much time to download from those servers I mean it takes days to download. I am from india which sever should I choose for fast download. I tried one two Asian but they also show the same error. Commented Feb 22, 2023 at 19:37
2

I changed default Mirror deb http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi to

deb https://raspbian.mirror.net.in/raspbian/raspbian/ buster main contrib non-free rpi

in

sudo nano /etc/apt/sources.list

Then sudo apt-get update and sudo apt-get upgrade. I also changed the http:// to https:// in the new mirror because it didn't worked with http://.

1
  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Commented Apr 14, 2023 at 14:44
0

This issue has been resolved, I face the same issue: following are the steps:

  1. change your location to GB
  2. change the repository to http://mirror.ox.ac.uk/sites/archive.raspbian.org/archive/raspbian
  3. restart the system
  4. Try upgrade

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.