I want to connect to my raspberry pi 3 model B V 1.2 to minicom using serial cable. I have attached serial cables to correct pins like this. enter image description here

image of my setup enter image description here

I have installed raspbian from the imager tool (64 bit). I have tried many solutions but still unable to get output in minicom. my config.txt is as follows




and my cmdline.txt is as follows dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=PARTUUID=f5569f9f-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait

I have also enabled serial from raspi-config. and console environment autologin instead of desktop.

The commands I used to connect are

minicom -b 115200 -D /dev/ttyUSB0

tio /dev/ttyUSB0

screen /dev/ttyUSB0 115200

but none of these work. Putty doesn't help either. Can anyone help me? :(

2 Answers 2


There are many things wrong with your question.

  1. There is NO 64bit raspbian.
  2. There is no point in trying otg on a Pi3 because it lacks the hardware.
  3. The correct serial port is /dev/serial0
  4. You have enabled console so any communication with be interspersed with console messages.

There are probably more but fix these first.


By default the rpi is using the serial for debugging. You will need to disable this. I have done it 6-7 years ago and I don't remember exactly how but have a look at this: How To enable Serial

Focus on "Serial has changed with Raspberry PI Version 3"

Bluetooth is now bound on serial so you need to disable that as well. Try following those instructions and let me know :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.