0

I am running XBian Beta 2. I have a external hdd connected using usb with this fstab entry

/dev/sda1       /media/mybook   ext3    defaults,noauto,user,exec,noatime       0       0       0

I want this disk to be available through samba. I added this to /etc/samba/smb.conf

[mybook]
    path = /media/mybook
    guest ok = yes
    read only = no
    force user = xbian
    browseable = yes

Those parameters are exactly the same as parameters for my home folder. The problem is that although I can delete files from the home folder, I cannot delete files from [mybook] using samba.

When I try do delete a file, I get

You require permissions from XBIAN\xbian to make changes to this file

All the files I want to delete using samba have owner set to xbian and permissions to 777.

What I am doing wrong?

1

In my options I don't have the

read only = no

option, but a

writable = yes

option.

Did you try this already?

Update: I tried the same as you: sharing a external HDD. The problem was, that the HDD was not mounted propperly. So only root could do anything on this directory. There were two methodes which worked for me.

1.

force user = root

2.

mount -o umask=007,gid=1000,uid=1003 /dev/sda1 /media/mybook

Here uid is the user-ID and gid is the group-ID. The correct IDs you can find out by

less /etc/passwd

But maybe you should first check your permissions

ls -la /media

to enshure, if it is the problem or not.

  • yes I did, no help – Igor Kulman May 19 '14 at 20:46
-3

try adding something like into your smb.conf:

force create mode = 0777
force directory mode = 0777
create mask = 0777
directory mask = 0777
  • Did not help and I guess it is only for creating files and directories, which I also cannot do – Igor Kulman Mar 3 '14 at 18:45
  • 1
    This also is a security mistake. World readable/writable files and Directories are seldom a good idea. – Steve Robillard Mar 4 '14 at 0:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.