2

I have the following hardware/software setup:

  • Sferalabs StratoPi Base (Raspberry Pi 3B+ with a HAT for RS232/485)
  • Distro built with Yocto and meta-raspberrypi on thud branch
  • U-Boot
  • SysVinit

I want to be able to free the GPIO 14/15 (TX/RX pins for UART) because the HAT needs these pins for RS232/485 communication.

As soon as I stop using U-Boot, the StratoPi device works and I can communicate with the devices on the RS485 bus. But I can't free the UART from getting used by Linux/U-Boot if I use U-Boot.

Does someone know how to make the UART pins available to the HAT?

I've tried to:

  1. Remove all references to ttyAMA0 in cmdline.txt and in /etc/inittab
  2. Patch U-Boot like here : https://stackoverflow.com/a/64583919/9077458
  3. Use pi3-disable-bt overlay

None of them worked for me.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.