I want to mount my external HDD, but my Raspberry Pi can't recognize anything.

I loaded usb-storage with modprobe, but if I insert the HDD into the USB port, nothing changes. I can't see any changes neither in the lsusb -l, nor in dmesg, nor in /var/log/everything.log. If I insert my mouse or keyboard, or USB hub, I can see that the system recognizes it, but if I insert the HDD I can't see anything. Like nothing happened.

What should I do to mount my external HDD?

I've tried it with two different HDDs; neither worked.

  • What does fdisk -l say? Aug 2, 2012 at 18:51
  • It only prints the sdcard, and its partitions. Aug 2, 2012 at 19:01
  • Hmm... USB 2.0 right? What happens when you try to mount the partition? What is the model of the external HDD? Aug 2, 2012 at 19:38
  • Is it self powered?
    – Jivings
    Aug 2, 2012 at 20:10
  • 6
    The raspberry pi can't provide enough power for the HDD then. Sorry, but it will never work without using a powered USB hub.
    – Jivings
    Aug 2, 2012 at 20:48

2 Answers 2


From comments:

This is usb powered hard disk (not external adapter), I cant mount because I cant see in the /dev, cant even see in the log if inserted or not (nothing changes in log, but when i plug in mouse or usb hub)

Unfortunately, the Raspberry Pi can often not supply enough power through the USB ports to support USB powered devices. My own external HDD does not work because of this, and I would assume you are encountering the same issue.

You can resolve this in one of 2 ways:

  • by using some sort of powered USB hub, which takes it's power from an external source, such as an AC adaptor.
  • by using a self-powered external hard drive, which again takes it's power from an external source, such as an AC adaptor.

If you look at the Raspberry Pi Schematics, on page 3, there is a 140mA fuse in series between the 5V supply and the Vcc of each of the USB ports. 140mA is not enough to run a USB HDD.

Not the answer you're looking for? Browse other questions tagged or ask your own question.