3

I tried to upload a folder on my Raspberry Pi using Cyberduck SFTP, this has ALWAYS worked for me, but now it doesn´t I have no idea why. Thank you in advance. Cyberduck

  • what folder are you trying to upload to (full path) and what user are you using to connect? – Steve Robillard Mar 4 '14 at 10:57
  • /Users/USERNAME/Desktop/world via SFTP to /home/pi/minecraft and the user is the standart user (pi) – user13272 Mar 4 '14 at 10:59
  • I used this method many times and it worked, but now it is something wrong with the read/write rights – user13272 Mar 4 '14 at 11:03
  • I also tried different network filemanagers (Cyberduck and ForkLift) – user13272 Mar 4 '14 at 11:08
  • file:/Users/USERNAME/Desktop/world -> sftp://192.168.0.218/home/pi/minecraft – user13272 Mar 4 '14 at 11:14
2

What is the output of executing this (on the Pi)?

ls -l /home/pi/minecraft

If the folder is, e.g., owned root and not world writable, regular users cannot place anything there.

| improve this answer | |
  • -bash: s: command not found – user13272 Mar 4 '14 at 11:30
  • I think you missed the 'l' in 'ls' – developius Mar 4 '14 at 11:31
  • ok, now the output is: total 0 – user13272 Mar 4 '14 at 11:37
  • Ok! Sorry, do: 'ls -l /home/pi | grep minecraft' without the quotes obviously! – developius Mar 4 '14 at 11:40
  • 6
    The minecraft folder is owned by root, which means regular users can't do anything to it. Execute "sudo chown pi:pi ~/minecraft" to fix. – Fred Mar 4 '14 at 16:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.