1

I have installed Raspbian from NOOBS onto Raspberry Pi. The RPi booted fine until I tried to install a program. Now I think it is trying to run a script on boot-up which is causing it to fail.

If I hold shift - I get back to the GUI desktop (I assume this is in recovery mode). How do I now get the RPi to boot up without holding the shift key?

Sorry - totally new at RPi and Raspbian

Thanks Scott

  • What program did you install? – lincb Mar 4 '14 at 12:51
  • I was trying to install a UPS software (UPSilon 2000). – ScottC Mar 4 '14 at 13:07
  • Have just tried a trick that I found on the web - which seems like it will get me back to square one (which is what I want)... When I was pressing left shift button - I don't think anything was happening - and was somehow managing to get back into the GUI... but now I have swapped the keyboard to the top USB port, and the mouse on the bottom one, and have held down the shift button - and now I think I am truly in recovery mode. Noobs is now asking me which operating system I want to install. This will hopefully erase my problem, and then I can start all over again. Not an issue in my case.. – ScottC Mar 4 '14 at 13:12
  • ok - that did not work. – ScottC Mar 4 '14 at 13:24
  • Am still getting "timeout waiting for hardware interrupt" errors. – ScottC Mar 4 '14 at 13:26
1

My problems with the Raspberry Pi booting up have now been resolved. When booting up using Raspbian OS - I was getting heaps of "timeout waiting for hardware interrupt" errors. The screen would scroll really quickly, then timeout errors would ensue, and it seemed like an endless loop. At first I could not get into recovery mode, but once I eliminated a 7-port powered USB hub from the equation, it would respond to the shift key (ie. by plugging keyboard and mouse directly into Rpi USB sockets). I tried installing some of the other operating systems that come with NOOBS, and I did not experience the hardware interrupt errors with the other operating systems, but when I installed Raspbian - the GUI would fail to boot. ANd I really wanted to to stick to Raspbian.

I did manage to get into the GUI every now and then by jumping into and out of the config file (in recovery mode), but this was not satisfactory. I then experimented with booting without anything but an HDMI cable (and power) attached. Suddenly, the GUI loaded without issue. I could then insert mouse and keyboard after the OS had booted up into the GUI. I booted up with mouse inserted on its own. But when I tried keyboard on its own - the problem returned. So this pointed to an issue with the keyboard. I was able to boot up without the keyboard and then successfully use the keyboard by plugging it in after boot up. I then tried the RPi attached to a monitor instead of TV - by using a HDMI to DVI cable. I had no problem booting up with keyboard attached.

So I am putting my problem down to a combination of a - rollup keyboard used in conjunction with a TV (using HDMI cable).

Possibly a power related issue - maybe the combination of keyboard and TV was drawing too much current from RPi on bootup? Who knows... but my problem is solved. I now can boot up successfully without any further issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.