1

I'm trying to use IDrive backup on a raspberry pi with raspbian bullseye (see os-release output below). To setup idrive you download some (perl) scripts, install some pre-requisites and then login to your account. I'm stuck at the install pre-requisites stage. IDrive requires the following packages

  • build-essential
  • sqlite3
  • perl-doc

I have these installed, once these are in place it then needs some perl modules (or libraries, not sure on the correct term).

  • perl -MCPAN -e 'install DBD::SQLite'
  • perl -MCPAN -e 'install common::sense'
  • perl -MCPAN -e 'install Linux::Inotify2'

When I try to run the first command it starts and then freezes at (I assume it is compiling) the step where it runs aarch64-linux-gnu-gcc [...options...] sqlite3.c. If I leave it, it pauses here for hours and, if I run this from ssh or the GUI, it freezes the whole pi (I can't move the mouse or connect via ssh), my only option is to pull the power. Initially, I can use Ctrl-C to fail but this results in the whole operation failing. I have managed to install the other modules but the DBD::SQLite just will not succeed.

I've tried running these scripts with and without sudo.

Does anyone have any idea what this could be or how I go about diagnosing and/or fixing what is going on?

cat os-release output:

PRETTY_NAME="Debian GNU/Linux 11 (bullseye)"
NAME="Debian GNU/Linux"
VERSION_ID="11"
VERSION="11 (bullseye)"
VERSION_CODENAME=bullseye
ID=debian
HOME_URL="https://www.debian.org/"
SUPPORT_URL="https://www.debian.org/support"
BUG_REPORT_URL="https://bugs.debian.org/"

Kep

1 Answer 1

0

You don't have to use CPAN for these, they're in the distribution. Here are the package names and the commands I used to find them:

  • libdbd-sqlite3-perl: apt search sqlite | grep perl
    • There's also an sqlite 2 package, if 3 doesn't work try that.
  • liblinux-inotify2-perl: apt search inotify | grep perl
  • libcommon-sense-perl: apt search sense | grep perl

This is from RpiOS 11 bullseye, but the package names have probably been the same for a long time.

1
  • 1
    For anyone else having this issue, I installed these packages using apt-get, and the idrive set up completed successfully.
    – Kepboy
    Mar 5, 2023 at 0:19

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .