As I said in the title, my RPi 3B just wont boot and has a stable red light.

I have tried the following:

  • Re-flashing using balena etcher and raspberry pi OS flasher
  • Using multiple different power supplies that are known good and enough for the RPi 3B.
  • Using a different SD card
  • Trying everything mentioned here

Any help is greatly appreciated!

  • Is this a new 3B? Has it ever worked? What size sd card? Is the sd card new? Have you got another Pi? Have you got an official Pi power supply?
    – CoderMike
    Mar 12 at 20:39
  • There is absolutely no point in asking an "it doesn't work" question unless you post diagnostics and explain EXACTLY what YOU did. If you tried EVERYTHING what else do you think we could add.
    – Milliways
    Mar 12 at 20:56
  • The pi has been with me since 2017, but I left it in my closet for like 1.5 years and I have just now come back to use it. The PSUs I used are a 5v 2.4 amps one, which did work in the past on my rpi and still works on other devices, and a 5v 1 amp one which used to work on the same rpi and still works on other devices. Also I tried the SD card I flashed for the rpi 3 on the rpi 4 and it booted up with no issues Mar 12 at 22:03
  • I don't know how to reply on this platform lol Mar 12 at 22:49
  • tried the SD card I flashed for the rpi 3 on the rpi 4 and it booted possibly a dirty/damaged SD card slot, or a dead pi. Does it output anything to the screen? Do you recall ever enabling USB boot, that could allow you to check if the SD slot is the only thing malfunctioning? Mar 13 at 8:27


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.