1

Context: I'm using this serial TTY cable to connect my Raspberry Pi 4B to my main laptop. Both run fully updated versions of Ubuntu 22.10, except the laptop runs the x64 version of course. I got the serial connection established via screen and the baud rate is stable at 115200. I can use xterm's resize command to make the size of the TTY fit my GNOME Terminal window's size which is very convenient.

Problem: When I launch a program such as htop, or any other program which fills a relatively large portion of the screen with the same color, it stays black. For example, my htop bar currently looks like this: screenshot 1 The green and blue bars are supposed to extend to the edges of the screen, but the parts to the right of the last character in the line remain black. I know that they are supposed to extend all the way because that's what it looks like when I'm connected to the same Raspi with the same laptop over SSH.

Another example is the dpkg-reconfigure console-setup screen: screenshot 2 You see in the top left corner the text is pink. Well, the whole screen (except for the dialog in the center) is supposed to be pink. This is what I mean by "simple graphics with lots of fill color".

While the TUIs are still fully functional, I would like to have this problem solved just in case it's part of a bigger one.

What I've Tried (and didn't work):

  • Restarting both the raspi and my laptop
  • Switching to a different shell (bash and sh)
  • Checking dmesg. I saw nothing related to the problem, but if you know something specific that shows up as soon as it boots I can post the log.
  • Update, July 3 2023: I switched back to Windows on my main laptop and this is still happening so it is definitely not a driver or low level issue. Also this now happens on and off, there's no way to know why, for some reason. It always happens in GNU Screen, but doesn't happen when I use cu to connect to the serial line instead.
2
  • I've never used the serial console much. What does echo $TERM say?
    – goldilocks
    Commented Mar 21, 2023 at 13:31
  • @goldilocks the output of echo $TERM is xterm-256color. The same is true when connecting over SSH Commented Mar 21, 2023 at 22:18

1 Answer 1

0

Update: I thought it was a problem with my shell but apparently it's not. It's some kind of mix of issues when using screen + tmux. Just use cu to connect instead.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.