0

My goal is to use a Raspberry Pi headless and control it with VNC over wifi. It's a model 4 B with 8 GB RAM, running 64-bit bullseye. It's configured as a routed wireless access point using hostapd and and dnsmasq. It's also configure as a Stratum 1 time server using gpsd and ntp. With ethernet connected, all works as desired, although the only way to get my desired screen resolution of 1920x1080 in VNC is to use an HDMI dummy plug (screen resolution is not the issue I'm attempting to deal with in this question). If ethernet is connected, it will boot fully. If ethernet is disconnected it stops at "NET_BOOT wait for link TFTP: 0.0.0.0". This seems to me to indicate that it has failed to boot from SD. SD boot is first, USB boot is second and network boot is third in the boot order. If I connect ethernet while the NET_BOOT line is displayed, it will resume boot to successful completion from SD. If I allow it to retry network boot before connecting ethernet, it will progress to USB boot. Then, when I manually exit USB boot (I don't recall the button I clicked) it boots to successful completion from SD. If I wait for about 20 minutes without intervening, it boots to successful completion from SD. The line immediately preceding the NET_BOOT line says "HID error 1"; this error shows each time it boots, whether successfully or unsuccessfully. I find no questions here discussing failure to boot when ethernet is disconnected.

5
  • 1
    Does this answer your question? Screen resultion when using VNC / headless
    – Milliways
    Commented Mar 29, 2023 at 6:28
  • @Milliways that does not help. The final comment in that thread (as of 3/29/23) describes my experience--the only way to get 1920x1080 is to use an HDMI dummy dongle. I discovered that it hangs at the NET_BOOT line whenever ethernet is disconnected, even when an HDMI monitor is attached. I'll modify my question to reflect this.
    – dcorsello
    Commented Mar 29, 2023 at 12:47
  • Have you ACTUALLY tried setting VNC resolution? It works fine for the rest of us. Your question is lacking any evidence and seems to be conflating 2 issues.
    – Milliways
    Commented Mar 29, 2023 at 13:00
  • @Milliways, please see my comment above. The issue is that it will not boot if ethernet is disconnected. Period. VNC is now disabled. I need to modify my question. No evidence? I've described my problem as best I can,
    – dcorsello
    Commented Mar 29, 2023 at 13:05
  • @Milliways, I'd like to add that I made it clear in my original post that my concern was that the system wouldn't boot, which is clearly different from any other post regarding VNC screen resolution. All other information I provided was to give as complete a picture of my system as possible. You chose to zero in on one bit of information and disqualify my question on that basis. This is disappointing.
    – dcorsello
    Commented Mar 29, 2023 at 16:57

1 Answer 1

0

A suggestion found here seems to have fixed the problem. I edited the EEPROM config using this command:

sudo -E rpi-eeprom-config --edit

and added the following two lines:

NET_INSTALL_ENABLED=0
NET_INSTALL_KEYBOARD_WAIT=0

The system now boots to completion faster than it has to date. The second line added to the EEPROM config has resolved the HID error I mentioned in my original post.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.