0

I have an IP camera connected to the Raspberry Pi. I am using ffplay to display the camera through rtsp and it works.

But I can't make it start when X starts.

I tried several route:

Note that following that previous link, I can start chrome alright but impossible to see anything from ffplay. It runs in the background (I can see it hugging the CPU through top) and no error message in the logs. But ffplay does not display any window. I tried delaying the start of ffplay with sleep but no luck.

Is there anything special about ffplay that makes it impossible to start? Any way out this bind?

1 Answer 1

0

I used sleep in the systemd service definition file like this:

ExecStart=sleep 20s && /bin/bash /home/pi/kiosk.sh

Which was the wrong thing to do. Apparently it messes the environment variable somehow. I moved the sleep in the shell script and all is well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.