0

I'm running a Plex server on my RPi3 with Raspberry OS Lite.

I've started running into an error when uploading files that I cannot set permissions/timestamp, error 3 Denied.

I've tried a few things, one being to log in as root. I've changed the password and enabled root login via sshd_config.

But, when I try to ssh as root, it still says the password is wrong and will not allow me to ssh into the root account.

1
  • 1
    Did you do anything recently that caused it? The first step is to trace what happened that caused this to happen. Think back to what you did before that issue happened. The second step is to see why it is doing that. Maybe it is interfering with something or editing something in the system that caused it to break. The third step is to fix it. Remove what is causing it.
    – LilData777
    Apr 6, 2023 at 1:49

1 Answer 1

1

Raspberry OS Lite doesn't have a root user!

Login as pi or another user (if you have created one) and use sudo to perform actions that needs elevated credentials.

And please post complete error messages and use the {} button to format it as code!

6
  • what? How come RPi OS Lite doesn't have a root user? Doesn't all linux distributions have a root?
    – LilData777
    Apr 6, 2023 at 17:19
  • 1
    @Friendlygabe777 Debian derived OS don't have a root USER which you can login to although it is possible to create one. There is a root account which you can access with sudo su.
    – Milliways
    Apr 6, 2023 at 22:11
  • @Milliways - in Debian you don't need to "create one" as you say, you just add a password to root and the existing root user can now be logged in to. root USER exists in Debian, just that logging in to root is disabled by virtue of the password field in /etc/shadow being * (like many other system accounts) Apr 7, 2023 at 1:02
  • Yes, that is what I thought.
    – LilData777
    Apr 7, 2023 at 17:08
  • @JaromandaX if you can't login you DON'T have a root USER. Adding a password enables login to the root account.
    – Milliways
    May 7, 2023 at 8:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.