-1

So I'm running Kali on my Raspberry PI Zero W and have a simple USB wifi card attached via USB (No hub). The Pi is set up headless, so no desktop, auto wif, I, or auto-login. I'm using the internal foramina ssh connection and the external one in monitor mode.

But when I'm starting it up it seems to always prioritize the theUSBb wifi card and won't even start the internal one so I just have connections via the wlan1 external card and ifconfig shows that wlan0 doesn't exist. But when I disconnect the external card it works just fine with wlan0, except sometimes it connects for a few seconds and then disappears again but wlan0 is still up.

On start-up, it always just says: "wlan1 link ready" with the external one attached. Only sometimes it works shortly and then breaks the connection with the internal one and with ifconfig again no wlan0.

Is there any way to maybe disable the external one till the boot is complete or start-up both?

4
  • 3
    kali is intended to be used by Linux experts. Not sure any of us here would call ourself a Linux expert. Perhaps ask on a kali forum.
    – joan
    Apr 20, 2023 at 9:12
  • Gonna try that too
    – Steve
    Apr 20, 2023 at 9:27
  • Do you have the same problem when you try this with some more user-friendly distribution like Raspberry Pi OS?
    – Bodo
    Apr 20, 2023 at 17:08
  • so after some testing it is really only on kali i encounter this problem
    – Steve
    Apr 20, 2023 at 17:39

1 Answer 1

0

So after playing around a bit, with iwconfig returns the wlan0 as down, so what i found out worked for me was to put

@reboot sudo ifconfig wlan0 up

into crontab to automaticly bring the card up again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.